View Issue Details

IDCategoryLast Update
0008341bugs2020-09-26 13:37
ReporterwargreenAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
Platformx86_64OSDebianOS VersionSID
Product Version6.2 
Fixed in Version 
Summary0008341: Audible saw at transport state change
DescriptionIn Ardour 6.2.112, I have an audible"sweek" at transport state change (play/stop, enter in the loop with my auto-loop script).
We can see a saw waveform during the anti-click fade. Screenshot of the output of ardour attached.
TagsNo tags attached.

Activities

wargreen

2020-07-28 13:37

reporter  

x42

2020-09-03 22:56

administrator   ~0025003

Reproduced using a -6dB DC-offset "wave" form. Constant signal level of 0.5 and fade out happens in steps.

fade-bug.png (53,180 bytes)
fade-bug.png (53,180 bytes)
fade-test.tar.xz (6,388 bytes)

x42

2020-09-03 23:00

administrator   ~0025004

This seems to be DiskReader::DeclickAmp::apply_gain() 16 sample steps.

x42

2020-09-03 23:55

administrator   ~0025005

Fixed in 6.2-239-g7a9d4b1f64

Fade length was increased to ~1/52Hz, and unrolling shortened to 4 sample.

anonymous

2020-09-26 13:37

viewer   ~0025058

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-07-28 13:36 wargreen New Issue
2020-07-28 13:37 wargreen File Added: Capture d’écran de 2020-07-28 15-31-43.png
2020-09-03 22:53 x42 Status new => confirmed
2020-09-03 22:56 x42 File Added: fade-bug.png
2020-09-03 22:56 x42 File Added: fade-test.tar.xz
2020-09-03 22:56 x42 Note Added: 0025003
2020-09-03 23:00 x42 Note Added: 0025004
2020-09-03 23:55 x42 Assigned To => x42
2020-09-03 23:55 x42 Status confirmed => resolved
2020-09-03 23:55 x42 Resolution open => fixed
2020-09-03 23:55 x42 Note Added: 0025005
2020-09-26 13:37 anonymous Note Added: 0025058
2020-09-26 13:37 anonymous Status resolved => closed