View Issue Details

IDCategoryLast Update
0008193bugs2020-07-01 16:21
ReportermrshroomyAssigned To 
Reproducibilityalways 
Status assignedResolutionopen 
Platformx86_x64OSArch LinuxOS VersionLatest
Product Version6.0 
Fixed in Version 
Summary0008193: No sound when you open a ardour project with pulseaudio
DescriptionThere's no sound when you open a project that you made if you use pulseaudio. The way to get the sound back is to go to Window -> Audio/Midi setup and then you need to stop and then start pulseaudio again to be able to hear sound in the ardour project.
Steps To ReproduceMake a ardour project with the pulseaudio backend and add any LV2 plugin that produces sound before you save the project and close ardour.

Open ardour again and then there's no sound in a midi track that you've recorded for example neither if you try to use the virtual midi keyboard.

You need to use my workaround to get the sound again.
TagsNo tags attached.

Activities

x42

2020-06-02 19:26

administrator   ~0024349

I cannot reproduce this.

mrshroomy

2020-06-03 09:43

reporter   ~0024364

It seems like this happens in alsa backend also, i get the same problem on compiled ardour, binary arch ardour and the ardour official demo. Its easy to fix by restarting the audio engine but i got no clue why it doesn't just work when you start ardour and open your project.

x42

2020-06-06 00:13

administrator   ~0024413

Odd that it happens with ALSA, too. Perhaps an issue with configuring the soundcard (sample-rate, buffersize changes)?

Regarding Pulse, could you try 6.0.59 (or later)? I've slightly changed initialization sequence. Perhaps that helps

mrshroomy

2020-06-06 12:38

reporter   ~0024420

How do i test the 6.0.59 version? Is it the ardour version you mean and do i need to compile it then?

x42

2020-06-06 17:08

administrator   ~0024424

Yes, either compile it, get a demo from https://nightly.ardour.org

mrshroomy

2020-06-06 18:32

reporter   ~0024425

https://imgur.com/JiUAkVZ.png
It is still not working when you open a project and you still need to manually restart the audio engine to get ardors audio to work again.
The plugin is also black everytime this bug happens until you restart the audio engine and ardour sound works again.

mrshroomy

2020-06-08 09:20

reporter   ~0024435

I found a quite interesting thing, this is the error when you first open a project and get no sound.

2020-06-08T11:15:24 [INFO]: harvid version: 803
2020-06-08T11:15:24 [INFO]: Loading menus from /opt/Ardour-6.0.70/etc/ardour.menus
2020-06-08T11:15:25 [WARNING]: Ambiguous latency for port 'MIDI/midi_out 1' (0, 1024)
2020-06-08T11:15:25 [INFO]: Loading user ui scripts file /home/mrshroomy/.config/ardour6/ui_scripts
2020-06-08T11:15:25 [INFO]: Loading plugin order file /home/mrshroomy/.config/ardour6/plugin_metadata/plugin_order
2020-06-08T11:15:25 [INFO]: Loading history from /home/mrshroomy/testy/testy.history

mrshroomy

2020-06-08 11:55

reporter   ~0024436

I have solved the issue, i know what the cause is now.
I use this https://imgur.com/qSznmtg.png to record midi with my computer keyboard and record some midi parts and then i save my project and close ardour. When i open ardour again then i get no sound because that midi input to midi output thing is still on from when i saved the project. If you turn it off before you save your project then you can open ardour and get sound directly. I think ardour should do that it doesn't save the midi input to output state as connected by default when you open a project.

paul

2020-07-01 16:21

administrator   ~0024544

"I think ardour should do that it doesn't save the midi input to output state as connected by default when you open a project."

You may think this, but I am absolutely certain that almost all of our other users would disagree.

Issue History

Date Modified Username Field Change
2020-06-02 15:51 mrshroomy New Issue
2020-06-02 19:26 x42 Note Added: 0024349
2020-06-03 09:43 mrshroomy Note Added: 0024364
2020-06-06 00:13 x42 Assigned To => x42
2020-06-06 00:13 x42 Status new => feedback
2020-06-06 00:13 x42 Note Added: 0024413
2020-06-06 12:38 mrshroomy Note Added: 0024420
2020-06-06 12:38 mrshroomy Status feedback => assigned
2020-06-06 17:08 x42 Note Added: 0024424
2020-06-06 18:32 mrshroomy Note Added: 0024425
2020-06-06 22:26 x42 Assigned To x42 =>
2020-06-08 09:20 mrshroomy Note Added: 0024435
2020-06-08 11:55 mrshroomy Note Added: 0024436
2020-07-01 16:21 paul Note Added: 0024544