View Issue Details

IDCategoryLast Update
0008183other2020-07-31 07:20
Reporterapoorv569Assigned Topaul 
Reproducibilityalways 
Status closedResolutionwon't fix 
PlatformGNU/LinuxOSArch LinuxOS Versionunknown
Product Version6.0 
Fixed in Version 
Summary0008183: unable to move VCA tracks up or down in editor view
Descriptioni can't seem to move VCA tracks up or down in the editor view, like you can move midi or audio tracks and bus with control and up arrow key. it would easier to manange project if u have VCA near the assigned tracks rather than scrolling up and down again.
TagsNo tags attached.

Activities

x42

2020-06-02 22:06

administrator   ~0024358

This is intentional. Like in the mixer window, VCAs are always last (on a separate pane). You can re-order VCA among themselves.

apoorv569

2020-06-03 02:04

reporter   ~0024360

ok, it would be nice to be able to move them up or down anywhere though.

don3

2020-06-04 02:55

reporter   ~0024372

This would be a "nice to have" for me too, in both the editor and mixer windows. The mixer part of it would mirror what I can do with some hardware mixers -- e.g, put a VCA for drums next to the drum channels [on one layer, and put just the VCA on other layer(s) with other instruments or with other VCAs -- although this part is OT from apoorv569's original request]. The separate pane is useful too, so I'm not advocating getting rid of that. I guess if one were dreaming and not too concerned with pesky details like how to implement it, it could be cool to allow managing (creating, deleting, naming(?), moving) panes and assigning "slots" (regular tracks, buses, VCAs) to panes. Just thinking out loud there, sorry..!

paul

2020-07-03 04:04

administrator   ~0024570

we tried this when VCAs where originally implemented. we made the specific decision that it led to too much potential confusion and/or requirements for user options. Ardour has way too many options already - each individual one that you want is great, but the overall effect is numbing.

so we're not going to do this, sorry. don3's idea stands more of a chance (probably related to groups in some way too), but it will not be much of a priority.

anonymous

2020-07-31 07:20

viewer   ~0024869

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-06-01 07:19 apoorv569 New Issue
2020-06-02 22:06 x42 Note Added: 0024358
2020-06-03 02:04 apoorv569 Note Added: 0024360
2020-06-04 02:55 don3 Note Added: 0024372
2020-07-03 04:04 paul Note Added: 0024570
2020-07-03 04:04 paul Assigned To => paul
2020-07-03 04:04 paul Status new => resolved
2020-07-03 04:04 paul Resolution open => won't fix
2020-07-31 07:20 anonymous Note Added: 0024869
2020-07-31 07:20 anonymous Status resolved => closed