View Issue Details

IDCategoryLast Update
0008161bugs2020-07-28 15:22
ReportermagnetophonAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformLinuxOSNixOSOS Version20.09pre
Product Version6.0 
Fixed in Version 
Summary0008161: Crash when exporting with analysis
DescriptionWhen I export something, while leaving "Analyze Exported Audio" enabled, Ardour crashes, leaving the following in the terminal:

Vamp::HostExt: Unable to load library "/nix/store/2i5m5l28g2njgyj5nsk15x752rzax969-ardour-6.0/lib/ardour6/vamp/libardourvampplugins.so": /nix/store/2i5m5l28g2njgyj5nsk15x752rzax969-ardour-6.0/lib/ardour6/vamp/libardourvampplugins.so: undefined symbol: kiss_fft_alloc
Vamp::HostExt::PluginLoader: No library found in Vamp path for plugin "libardourvampplugins:ebur128"
[1] 730 segmentation fault (core dumped) ardour6 /home/bart/ardour/factoryGirl/factoryGirl.ardour
TagsNo tags attached.

Activities

x42

2020-05-30 03:27

administrator   ~0024306

Last edited: 2020-05-30 03:27

View 2 revisions

The underlying issue is probably the same as
https://discourse.ardour.org/t/undefined-symbol-exp2f-finite/103943 - your distro provided qm-dsp is underlinked against libm and or kiss_fft.

Since 6.0-35-gfe1f8effb9 optimized builds don't crash anymore, but analysis remains unavailable if the VAMP plugin cannot be loaded.

anonymous

2020-07-28 15:22

viewer   ~0024838

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-05-29 15:21 magnetophon New Issue
2020-05-30 03:27 x42 Assigned To => x42
2020-05-30 03:27 x42 Status new => resolved
2020-05-30 03:27 x42 Resolution open => fixed
2020-05-30 03:27 x42 Note Added: 0024306
2020-05-30 03:27 x42 Note Edited: 0024306 View Revisions
2020-07-28 15:22 anonymous Note Added: 0024838
2020-07-28 15:22 anonymous Status resolved => closed