View Issue Details

IDProjectCategoryView StatusLast Update
0008142ardourbugspublic2020-05-30 17:06
Reportermantis_n1oif Assigned To 
Status newResolutionopen 
PlatformSome Other LinuxOSSome Other LinuxOS Versionunknown
Product Version6.0 
Summary0008142: Ctrl + ? and Ctrl + ? don't move tracks up and down
DescriptionCtrl + ? and Ctrl + ? don't move tracks up and down anymore.

Track ?"move track up/down" still works, though.
Steps To ReproduceOpen a session with multiple tracks. Try Ctrl + ? or Ctrl + ?
TagsNo tags attached.



2020-05-27 17:40

administrator   ~0024282

This bug report shows "Ctrl-?" for two different keys. I assume this is a formatting error.

Ctrl-UpArrow and Ctrl-DownArrow move the currently selected tracks up and down when tested here.


2020-05-28 13:06

reporter   ~0024292

Ctrl-UpArrow and Ctrl-DownArrow still don't move tracks for me. I'm on Ubuntu 20.04 stock Gnome.


2020-05-29 18:55

reporter   ~0024299

Same issue here on Ubuntu 19.10. Additionally, the UpArrow and DownArrow keys would not vertically scroll through the tracks. I found that clicking the mouse on empty space in the Editor Mixer restored correct operation. Once restored, clicking anywhere else (an empty track lane for example) would once again cause the loss of Ctrl-UpArrow, Ctrl-DownArrow, UpArrow and DownArrow functions until once again clicking in the Editor Mixer.


2020-05-29 20:06

administrator   ~0024300

If you enter "Draw" or "Internal Edit" mode for the mouse, there are a new set of keybindings used to edit MIDI notes, which include the arrow keys. This could be part of the explanation here, perhaps?


2020-05-29 21:20

reporter   ~0024303

The issue occurred after opening a new session, adding a midi track, 1 audio bus and 19 audio tracks, to be used as a template. I did try entering draw, grab and range modes, though there was no recorded data at the time. The session was re-opened three times with the same result. It was as if the editor window lost keyboard focus until I clicked in the mixer strip, though other key combos like CTRL+E worked. After reading your response I manually added a few midi notes and checked the new key bindings you mentioned. They all worked fine and I haven't been able to reproduce the issue since then. I even created a new, essentially identical, session without the same issue. I hate it when that happens! I'll chime in again if necessary and if I have any more details. Thanks for the amazing work and dedication!


2020-05-29 21:45

administrator   ~0024304

The editor window didn't lose focus - you were in draw or internal edit mode. There are various ways to leave that mode and/or have the MIDI editing bindings ignored. Clicking in the mixer strip moved the keyboard focus back to the mixer strip ...

mantis_n1toif ... you might want to check on this stuff too, since I suspect it is the source of your problem too.


2020-05-29 22:39

reporter   ~0024305

Right you are Paul. I just confirmed it. I missed the fact that the mouse cursor looks the same in the grab and internal edit modes. Another day, a little more experience. Thanks again.


2020-05-30 16:18

reporter   ~0024314

Ctrl up/down works for me in all modes except draw and internal edit. I'm usually in draw mode, so that was the confusion. I assume it should work in all modes? Thanks for taking care of this.


2020-05-30 17:06

administrator   ~0024315

no, it will not work in draw mode because the MIDI editing bindings take precedence.

Issue History

Date Modified Username Field Change
2020-05-24 18:41 mantis_n1oif New Issue
2020-05-27 17:40 paul Note Added: 0024282
2020-05-28 13:06 mantis_n1oif Note Added: 0024292
2020-05-29 18:55 rlapick Note Added: 0024299
2020-05-29 20:06 paul Note Added: 0024300
2020-05-29 21:20 rlapick Note Added: 0024303
2020-05-29 21:45 paul Note Added: 0024304
2020-05-29 22:39 rlapick Note Added: 0024305
2020-05-30 16:18 mantis_n1oif Note Added: 0024314
2020-05-30 17:06 paul Note Added: 0024315