View Issue Details

IDCategoryLast Update
0008105bugs2020-05-18 20:17
ReporterMMP404Assigned Tox42 
Reproducibilityalways 
Status assignedResolutionopen 
PlatformDebian OSLinuxOS Version10.2
Product Version6.0-pre1 
Fixed in Version 
Summary0008105: Control Surface Incoming connection lost
DescriptionControl Surface Incoming connection lost switching between tracks. Control Surface Incoming connection not connected on startup.
I save this setting in template and save session immediately. Immediately after session startup Edit->Preferences->Control Surfaces->General MIDI shows Disconnected, and after track activation change. MIDI notes are still input on both tracks.
Steps To ReproduceCreate a template and setup General MIDI mapping. Verify mapping works when control surface transport button pressed.
Save template.
Create a session from this template.
Add a MIDI track.
Verify mapping works when control surface transport button pressed.
Add another MIDI track.
Does mapping still work when control surface transport button pressed?
Switch between tracks.
Does mapping still work when control surface transport button pressed?
Save session and exit, restart and open session.
Does mapping still work when control surface transport button pressed?

Check Edit->Preferences->Control Surfaces->General MIDI shows in Disconnected?


TagsNo tags attached.

Activities

x42

2020-05-11 18:25

administrator   ~0024122

Check Preferences > MIDI

If you you have "MIDI Input follows track selection" enabled, and the MIDI device in question is not marked as control-surface but "Music Data" this would be expected result.
Selecting a MIDI track re-connects the input to the given MIDI track.

MMP404

2020-05-18 14:39

reporter   ~0024187

Sorry for delayed response. I needed to research my configuration before proceeding.

... my MIDI device *IS* marked as control-surface for "Control Data" *AND* "Music Data"... yes, Both.... and Yes it works.... until it doesn't

Without MIDI follow ::
In Preferences-> MIDI I configure MIDI input 1 : Music Data AND Control Data - my MIDI mapping and Music input capability BOTH continue to function as I switch between tracks.

Now ADD MIDI follow to config ::
 Preferences-> MIDI I configure MIDI input 1 for "Music Data" and "Control Data" and "Follow Selection" - my MIDI mapping instantly STOPS working when I select a different track. Music Data does input on newly activated track.

Why would MIDI input reconnect for Music Data and NOT reconnect for Control Data?

paul

2020-05-18 20:17

administrator   ~0024192

Being marked for control data has nothing to do with per-track input. Control data is not sent to tracks, but to control surfaces. The point of marking a device in this way is really a way of saying "NOT musical data", which is somewhat redundant.

It is hard to describe these options in a way that more than a small fraction of users can understand.

Issue History

Date Modified Username Field Change
2020-05-10 13:28 MMP404 New Issue
2020-05-11 18:25 x42 Assigned To => x42
2020-05-11 18:25 x42 Status new => feedback
2020-05-11 18:25 x42 Note Added: 0024122
2020-05-18 14:39 MMP404 Note Added: 0024187
2020-05-18 14:39 MMP404 Status feedback => assigned
2020-05-18 20:17 paul Note Added: 0024192