View Issue Details

IDCategoryLast Update
0008096bugs2020-07-07 11:37
ReporterprusnakAssigned Topaul 
Reproducibilityalways 
Status closedResolutionno change required 
PlatformSome Other LinuxOSSome Other LinuxOS Versionunknown
Product Version6.0-pre1 
Fixed in Version 
Summary0008096: Compilation fails on 6.0-rc1
DescriptionI am trying to compile tag 6.0-rc1 and the compilation fails with:

[ 87/1050] Compiling libs/ardour/sse_functions_64bit.s
as: invalid option -- 'U'
TagsNo tags attached.

Activities

prusnak

2020-05-08 11:39

reporter   ~0024097

$ as --version
GNU assembler (GNU Binutils) 2.31.1
Copyright (C) 2018 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public License version 3 or later.
This program has absolutely no warranty.
This assembler was configured for a target of `x86_64-unknown-linux-gnu'.

x42

2020-05-08 12:44

administrator   ~0024099

Which distro is this? how have you configured Ardour?

There is a dedicated case when cross-compiling for windows Windows that might also be relevant for your case:
https://github.com/Ardour/ardour/blob/master/libs/ardour/wscript#L380-L383

Could you try to remove the "if" clause and see if that also solves the issue for you?

prusnak

2020-05-08 14:16

reporter   ~0024104

The distro is NixOS.

I confirm that removing the "if" clause fixed the issue.

anonymous

2020-07-07 11:37

viewer   ~0024626

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-05-08 11:37 prusnak New Issue
2020-05-08 11:39 prusnak Note Added: 0024097
2020-05-08 12:44 x42 Note Added: 0024099
2020-05-08 14:16 prusnak Note Added: 0024104
2020-07-03 05:36 paul Assigned To => paul
2020-07-03 05:36 paul Status new => resolved
2020-07-03 05:36 paul Resolution open => no change required
2020-07-07 11:37 anonymous Note Added: 0024626
2020-07-07 11:37 anonymous Status resolved => closed