View Issue Details

IDCategoryLast Update
0007996bugs2020-07-11 06:56
ReporterOliverAssigned Tojohmue-eo 
Reproducibilityalways 
Status assignedResolutionreopened 
Platformx86_64OSXubuntuOS Version18.04LTS
Product Version6.0-pre1 
Fixed in Version 
Summary0007996: Crash of 5.12 after session touched with 6.0-pre1
DescriptionAn empty session created in 5.12 makes 5.12 crash if it has been opened once with Ardour-6.0.pre1.208 (from https://nightly.ardour.org/). It does not matter if I try to open the backup session created by 6.0 with suffix -3002, or the latest one.

I don't use a debug built for 5.12, but the last messages in the terminal are

terminate called after throwing an instance of 'PBD::unknown_enumeration'
  what(): unknown enumerator Samples in PBD::EnumWriter
Aborted
Steps To Reproduce- Create an empty session with Ardour 5.12, save the session, and quit.
- Open in Ardour-6.0.pre1.208 and just quit again (no saving).
- Try to open again in Ardour 5.12 -> crash.
Additional InformationThis also happened with previous nightlies. It crashes also in 'Safe mode' (but there are no plugins, anyway).
TagsNo tags attached.

Activities

johmue-eo

2020-04-08 20:14

developer   ~0021258

I can't reproduce this here.

Can you try the following:
- Create an empty session with Ardour 5.12, save the session, and quit.
- Copy the file "instant.xml" of the session folder somewhere (like to /tmp)
- Open in Ardour-6.0.pre1.208 and just quit again (no saving).
- Copy the "instant.xml" that you copied somewhere back to the session folder
- Try to open again in Ardour 5.12 and see if it crashes.

Oliver

2020-04-08 20:23

reporter   ~0021259

Indeed it does not crash in 5.12 if I use the saved "instant.xml", neither with the -3002 session nor with the normal one.

I also saved the version of the file after opening in Ardour-6.0.pre1.208. Ardour 5.12 crashes again if I use this one.

johmue-eo

2020-04-09 12:01

developer   ~0021267

So it reproducibly crashes as soon as the "instant.xml" that Ardour6 has touche is in place?

Maybe you can attach the session file and the two instant.xml, one of which makes Ardour5 crash and the other doesn't.

Oliver

2020-04-09 18:23

reporter   ~0021271

Sadly... today, I cannot reproduce it with the exact same recipe that I put down yesterday. Ardour 5.12 does not crash today on a session touched with 6.0-pre1 (same version).

Interestingly, I even did revive a real session (not a test) that I could not open in Ardour 5.12 anymore because of (I thought) this issue by deleting the 'instant.xml' - and it opened again in 5.12.

That is strange. The recipe is very simple and I tried yesterday on three new sessions. Earlier yesterday, I was playing with ggc4/gcc5 versions of Ardour in connection with another bug report (ID 0007992), but I have used always the same version for the test of this issue.

Oliver

2020-04-10 18:44

reporter   ~0021285

Still could not reproduce today with Ardour-6.0.pre1.208.

For the first time, I observed today a warning in 5.12 that a session could not be loaded because it was generated with a more recent version of Ardour. The warning is as expected, but I did not get this warning before.

Oliver

2020-07-09 23:11

reporter   ~0024669

After installing Ardour 6.2, this happens again now, with the same message in a terminal.

This time, I opened an old session previously used in Ardour 5.12, and Ardour 6.2 created the -3002 copy of the session. Ardour 5.12 now crashes as described with both sessions ('normal' and -3002).

Oliver

2020-07-09 23:15

reporter   ~0024670

Attached the instant.xml file of the session that crashes Ardour 5.12. As suggested before, deleting this file stopped Ardout 5.12 from crashing.

Oliver

2020-07-09 23:25

reporter   ~0024671

Looks like attaching failed. Try again, now also the session file.

instant.xml (2,158 bytes)
Layla (Ardour)-3002.ardour (81,459 bytes)

paul

2020-07-11 03:21

administrator   ~0024683

this is sort of a design-error, sort of unavoidable error. we copy the .ardour file for safe-keeping, but instant.xml (used to store settings that should always be stored "instantly" rather than on explicit save) is in some senses "part of" the session too.

the versioning provided for the .ardour file is not done for the instant.xml file, which can lead to this sort of problem. The session can still be opened as you've discovered ... i'm not sure how much of a priority we would put on versioning the instant.xml file as well as the .ardour file.

there is a case for doing so, don't mistake what i'm saying. i think it's just going to be low priority.

Oliver

2020-07-11 06:56

reporter   ~0024691

This is maybe less an issue now that the new release is out and hopefully there is no need to go back to Ardour 5.12 for work on older sessions. Judging from what I see in instant.xml, simply deleting it does not destroy too valuable information, but only things like window positions and clock mode.

However, during testing towards 6.0 is was VERY (if possible I'd also underline this word) disconcerting to suddenly see Ardour 5.12 crash when trying to open a production session after just touching it with the new version (no saving!).

Apparently not many other people have found this behaviour, maybe it is particular to my computer, but fixing it for the next major release would be appreciated.

Issue History

Date Modified Username Field Change
2020-04-08 19:09 Oliver New Issue
2020-04-08 20:14 johmue-eo Assigned To => johmue-eo
2020-04-08 20:14 johmue-eo Status new => feedback
2020-04-08 20:14 johmue-eo Note Added: 0021258
2020-04-08 20:23 Oliver Note Added: 0021259
2020-04-08 20:23 Oliver Status feedback => assigned
2020-04-09 12:01 johmue-eo Status assigned => feedback
2020-04-09 12:01 johmue-eo Note Added: 0021267
2020-04-09 18:23 Oliver Note Added: 0021271
2020-04-09 18:23 Oliver Status feedback => assigned
2020-04-10 18:44 Oliver Status assigned => closed
2020-04-10 18:44 Oliver Resolution open => unable to reproduce
2020-04-10 18:44 Oliver Note Added: 0021285
2020-07-09 23:11 Oliver Status closed => feedback
2020-07-09 23:11 Oliver Resolution unable to reproduce => reopened
2020-07-09 23:11 Oliver Note Added: 0024669
2020-07-09 23:15 Oliver Note Added: 0024670
2020-07-09 23:15 Oliver Status feedback => assigned
2020-07-09 23:25 Oliver File Added: instant.xml
2020-07-09 23:25 Oliver File Added: Layla (Ardour)-3002.ardour
2020-07-09 23:25 Oliver Note Added: 0024671
2020-07-11 03:21 paul Note Added: 0024683
2020-07-11 06:56 Oliver Note Added: 0024691