View Issue Details

IDCategoryLast Update
0007966bugs2020-07-16 18:41
ReporterjumaseAssigned Tox42 
Reproducibilityalways 
Status feedbackResolutionreopened 
PlatformAMD64OSDebian GNU/LinuxOS Version10.3 (buster)
Product Version6.0-pre1 
Fixed in Version 
Summary0007966: "Snapped cursor" (the blue line) remains at a fixed position when switching the Edit Point from Mouse to Playhead
DescriptionWhen the Edit Point is Playhead, the blue line remains visible and also stays at the same position (the same pixels are blue) no matter how much you zoom in/out (staying at the begining of the session). It only desappears when you drag the playhead to zero position. But if you move it away from there, the blue line appears again.
Steps To Reproduce1. Set the Edit Point to Mouse and make the blue line appear by hovering over the editor
2. Switch the Edit Point to Playhead
3. Zoom in and out (always at the begining of the session) and the blue line would be at the same position in the screen, never disappearing.
Additional InformationPreferences > Show "snapped cursor" must be enabled.
Tested with Ardour-6.0.pre1.68
TagsNo tags attached.

Activities

x42

2020-04-01 20:55

administrator   ~0021128

Fixed in 6.0-pre1-87-ga6c9c04fd6

anonymous

2020-05-30 23:10

viewer   ~0024316

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

jumase

2020-07-16 18:41

reporter   ~0024753

Hi, I'm afraid this is not solved. Sorry but I wasn't able to test it until recently. I can add that, appart from displaying the blue line at the same position on the screen when switching the edit point back to playhead,
1- it always appears on session startup at time zero (altough you previously set edit point to playhead);
2- it doesn't disappear unless you click on the ruler (you can "move" playhead with "P" key, or zoom in and out, but the blue line remains there);

In order to reproduce both items, you have to tick Preferences > Editor > Snap > Show "snapped cursor".
Number 1: create a session, set edit point to playhead and move playhead away from zero time, close session, re-open. The blue line displays at the begining of the timeline altough the edit point actually IS playhead (you can, for example, split a region and it will split under playhead, not under the blue line).
Number 2: create a session, set edit point to mouse (press "2" key), move the edit point (the blue line) away from zero, set the edit point back to playhead with the "2" key. Then you can "move" playhead to a different position and edit point will be playhead as it's supposed to be, but the blue line is still there on the screen at a fixed position, even though you zoom in and out. You can, for example, split a region and the split will be performed at playhead, not the blue line.

Issue History

Date Modified Username Field Change
2020-03-31 23:09 jumase New Issue
2020-04-01 20:55 x42 Assigned To => x42
2020-04-01 20:55 x42 Status new => resolved
2020-04-01 20:55 x42 Resolution open => fixed
2020-04-01 20:55 x42 Note Added: 0021128
2020-05-30 23:10 anonymous Note Added: 0024316
2020-05-30 23:10 anonymous Status resolved => closed
2020-07-16 18:41 jumase Status closed => feedback
2020-07-16 18:41 jumase Resolution fixed => reopened
2020-07-16 18:41 jumase Note Added: 0024753