View Issue Details

IDCategoryLast Update
0007948bugs2020-04-01 16:29
ReporteruniusAssigned Topaul 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformLinux 32-bit gcc4OSOS Version
Product Version6.0-pre1 
Fixed in Version 
Summary0007948: Crash on add track
DescriptionCrash on add Audio or MIDI track
Steps To Reproduce1. add Audio track
Additional InformationOn Nightly Build Debug this issue does not appear, only on Optimized build
6.0.pre1.15
TagsNo tags attached.

Activities

unius

2020-03-28 11:22

reporter   ~0021069

This issue appeared after 6.0.pre0.3766

unius

2020-03-29 09:34

reporter   ~0021091

if I build 6.0.pre1.26 from git without --optimize,
when starting from the terminal, after adding a track:
ardour: /include/boost/smart_ptr/shared_ptr.hpp:734: typename boost::detail::sp_member_access<T>::type boost::shared_ptr<T>::operator->() const [with T = ARDOUR::Playlist; typename boost::detail::sp_member_access<T>::type = ARDOUR::Playlist*]: Assertion `px != 0' failed.

Oliver

2020-03-30 17:59

reporter   ~0021109

Seems to be a duplicate of 0007958 (now fixed). To credit right, this report by unius was submitted earlier.

paul

2020-04-01 16:13

administrator   ~0021125

please mark as closed.

Issue History

Date Modified Username Field Change
2020-03-28 10:54 unius New Issue
2020-03-28 11:22 unius Note Added: 0021069
2020-03-29 09:34 unius Note Added: 0021091
2020-03-30 17:59 Oliver Note Added: 0021109
2020-04-01 16:13 paul Assigned To => paul
2020-04-01 16:13 paul Status new => resolved
2020-04-01 16:13 paul Resolution open => fixed
2020-04-01 16:13 paul Note Added: 0021125
2020-04-01 16:29 unius Status resolved => closed