View Issue Details

IDCategoryLast Update
0007932bugs2020-07-06 02:48
ReporterlbrAssigned Topaul 
Reproducibilityalways 
Status closedResolutionnot fixable 
PlatformWindows 10OSWindowsOS Version10
Product VersionMixbus 6.x 
Fixed in Version 
Summary0007932: LTC output assign not saved
DescriptionSelect an output for LTC and save project. Open project connection not remembered.
Steps To Reproduceas above
TagsNo tags attached.

Activities

x42

2020-04-02 14:52

administrator   ~0021135

LTC output is usually a studio setup, the connection is a session-independent configuration.

Ardour used a "hidden" preference for that. Now since 6.0-pre1-97-g849bce6e4d it is exposed in the dialog: Preference > LTC > Port..

lbr

2020-04-04 04:44

reporter   ~0021161

ardour should absolutely remember that config per session. it is a per session function.

lbr

2020-04-04 04:45

reporter   ~0021162

to be clear Robin, I am referring to Ardours LTC output

x42

2020-04-04 11:59

administrator   ~0021166

This is for the LTC generator, It's a dedicated session-independent output port.

If you synchronize a video projector or some other equipment using timecode, this setup should not depend on the session, but on the studio were Ardour is used it,

lbr

2020-04-04 22:27

reporter   ~0021172

I fail to see the reasoning. MTC output assignments are saved per session. why not LTC? makes no sense at all. it is required.

x42

2020-04-05 22:16

administrator   ~0021200

The main reason is that LTC generator is a preference (session independent).
I'd argue that, since MTC generator is also a preference, it should behave like current LTC, and use a fixed default auto-connection in preferences.

The root of the issue is that due to historical reasons (JACK), Ardour only saves current connections. So when you move a session around, connections can be lost.
e.g. connect some output to "playback_17", then open+save the session on a laptop with stereo sound-card out only, and later open it on a studio box again.

On the laptop the LTC generator may not even be enabled (it's a session-independent preference), and on the studio machine it is rather inconvenient that the connection is not set.

mid/long term Ardour should remember connections per interface, which is a prerequisite to properly addressing this issue.

lbr

2020-04-08 01:35

reporter   ~0021247

In my experience this kind of setup is always static, and therefore must be part of the saved session. It's changeable anyway, so why not give userland what it wants? My equipment doesn't change between sessions ,but if it did, I can change it. I recommend not changing the current MTC save status for certain ! my 2c

paul

2020-07-03 05:41

administrator   ~0024591

Our rule of thumb is this: you can move the session to a new hardware setup. Therefore anything related to hardware (connections etc.) is not part of the session state. It is part of the program's global state (a "Preference" rather than a session property). You may never change the equipment that you're using, but then there's no reason to worry about it being a global setting.

The MTC connections should be handled in the same way, we just (currently) do not.

lbr

2020-07-06 01:08

reporter   ~0024610

A total corner case at best. You own the HW you own. I want my DAW to control my HW AND routing for simplicity and consistency. I do not ever change my hardware. I can, but I simply don't. If I go to another studio I export stems. Why would I want to use my system with their HW? Your reasoning is just not real world in my experience. And Robin says he's like to remove this function altogether. For such a rare occurrence it seems crazy to me. MB/Ardour often just makes work for the end user for no real gain imho. Anyway, I guess I just wait till it's removed.

paul

2020-07-06 02:06

administrator   ~0024611

Your reasoning seems backwards to me.

The session is movable. Your hardware is not. Therefore the immutable aspects of things ("where to connect LTC to") is associated with your hardware, not with the session.

Storing it as part of overall application preferences thus keeps it associated with "your" setup.

Putting it in the session associates it with the session, which is (theoretically) mobile.

The former will get you want you want, and what other people want to. The latter will get you what you want, but doesn't work for other users or workflows.

lbr

2020-07-06 02:33

reporter   ~0024612

What? Of course my hardware is moveable. AND the session is intrinsically linked to my HW. Always. But me and my backward reasoning are giving up on your project. Good luck

paul

2020-07-06 02:48

administrator   ~0024613

user has abandoned use of software.

anonymous

2020-07-06 02:48

viewer   ~0024614

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-03-16 20:12 lbr New Issue
2020-04-02 02:58 x42 Assigned To => x42
2020-04-02 14:52 x42 Note Added: 0021135
2020-04-02 14:52 x42 Status new => feedback
2020-04-04 04:44 lbr Note Added: 0021161
2020-04-04 04:44 lbr Status feedback => assigned
2020-04-04 04:45 lbr Note Added: 0021162
2020-04-04 11:59 x42 Note Added: 0021166
2020-04-04 22:27 lbr Note Added: 0021172
2020-04-05 22:16 x42 Note Added: 0021200
2020-04-05 22:17 x42 Assigned To x42 =>
2020-04-08 01:35 lbr Note Added: 0021247
2020-07-03 05:41 paul Note Added: 0024591
2020-07-06 01:08 lbr Note Added: 0024610
2020-07-06 02:06 paul Note Added: 0024611
2020-07-06 02:33 lbr Note Added: 0024612
2020-07-06 02:48 paul Assigned To => paul
2020-07-06 02:48 paul Status assigned => resolved
2020-07-06 02:48 paul Resolution open => not fixable
2020-07-06 02:48 paul Note Added: 0024613
2020-07-06 02:48 anonymous Note Added: 0024614
2020-07-06 02:48 anonymous Status resolved => closed