View Issue Details

IDProjectCategoryView StatusLast Update
0007929ardourbugspublic2020-03-18 16:35
ReporterKreap Assigned To 
Status newResolutionopen 
PlatformWindows 10OSWindowsOS Version10
Product VersionMixbus 6.x 
Summary0007929: MCP Automation write errors
Description I'm on the win 10 hotfix and it's not crashing writing fader automation but it's not acting right either.

I went to write basic fader automation in touch mode today, it's holding my control correctly and it seems to want to cling to the vertical extreme end like top or bottom.

I hadn't changed any mackie or automation thinning settings the default setting worked fine for me on v5 in MCP or Generic midi controller.

Here is one screenshot:

Steps To ReproduceSo I trashed config file and started a new test session and it wont find the faders at all. I kept adding tracks and none of them appear to be available to bank. Usually I could at least control the buss faders.

So I switched my fw1082 into midi mode and assigned it as a generic controller and wrote a passage of fader automation.

Next screenshot:

I rebooted this test session many times over and it wont find any mackie faders. Transport and shuttle will move the playhead fine. My master fader is assigned to monitor by default.

All this stuff worked fine in v5 and still does when I load it up, double checked by loading reaper. My hardware is working correctly.

I re toggled all the MCP settings and midi connections but still nothing, there is no feedback going to my tascam SOFTLCD either.

The black bar at the bottom of this image is my SOFTLCD, It's empty but should be showing the latest set of 8 faders i'm banked to:

A session from v5 loaded into v6 seems to have the feedback but very buggy auto data in any write mode. thinning settings dont change it. you can see the softlcd has feedback here:

adding a new track in the session from v5 with no grouping or vca to possibly override the controller. :

I can't seem to get the test session to discover faders, tried the calibration option in the MCP window but there is no instructions in the manual or the ardour manual. It does nothing if I push the button.

The master settings asks me to connect the fw control in to fw control out, it's not possible to do this with a cable because there are no midi ports. I dont know any MCU controllers that use hardware midi ports to connect. Usually these are virtual ports.

I tried hitting the discover mackie devices button, nothing happens and again I couldnt find any info in either manual to explain how this works and what it does.

It crashed playing back the automation a couple of times but not recording it. Faders go wild and chatter back and forth and the screen freezes.
Additional InformationAgain like I said no thinning settings change this, I retried with different faders on my device just to rule out the physical hardware. The touch sensitivity seems to work fine with the other DAW's and v5. I'm also not dead. I'm quite able to complete the touch sensitive circuit and the air humidity and such is fine.
TagsMCP automation error



2020-03-18 16:35

reporter   ~0021033

Here's a suggestion which might just help - though admittedly it's a long shot...

Next time you launch Mixbus, click on 'Window->Preferences->Show->Control Surfaces' and verify that Mackie is the only option selected. I've a feeling that something in Mixbus can change those settings without the user's knowledge (it's happened to me twice in the past few days...)

Very much a long shot - but worth checking.

Issue History

Date Modified Username Field Change
2020-03-16 13:14 Kreap New Issue
2020-03-16 13:14 Kreap Tag Attached: MCP automation error
2020-03-18 16:35 johne53 Note Added: 0021033