View Issue Details

IDCategoryLast Update
0007914bugs2020-04-26 19:26
Reportermantis_n1oifAssigned Tox42 
Reproducibilitysometimes 
Status closedResolutionfixed 
PlatformSome Other LinuxOSSome Other LinuxOS Versionunknown
Product Version6.0-pre0 
Fixed in Version 
Summary0007914: Active automations lanes sometimes do not appear when they should
DescriptionSometimes I'll have an automation lane that disappears. You click through the automation menu and it shows as "checked" meaning it should be in the list. But it isn't. You click it once and it gets unchecked (and still does not appear) but then you click it a second time and the lane will finally appear.

I do not know why this happens on some automations and not others (even within the same plugin). Maybe the difference is binary vs spectrum? I.e. enable/disable will show up, but a value between 0-10 automation lane has this issue?
Steps To ReproduceSee attached graphic.
TagsNo tags attached.

Activities

mantis_n1oif

2020-02-26 19:26

reporter  

no_output_gain.jpg (320,116 bytes)

x42

2020-02-28 01:29

administrator   ~0020986

This should be fixed in 6.0-pre0-3550-g1af5f37e46
On session re-load, previously lanes that had no events were not displayed (even if they were marked as visible).

It might also be due to a related bug: When copying plugins (or plugin state) the control-IDs were copied, too. So GUI state is messed up: The "visibility ID" is used for multiple lanes (copies of the plugin).
If this is the case, it can still be a problem for existing sessions.

anonymous

2020-04-26 19:26

viewer   ~0023937

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2020-02-26 19:26 mantis_n1oif New Issue
2020-02-26 19:26 mantis_n1oif File Added: no_output_gain.jpg
2020-02-28 01:29 x42 Assigned To => x42
2020-02-28 01:29 x42 Status new => resolved
2020-02-28 01:29 x42 Resolution open => fixed
2020-02-28 01:29 x42 Note Added: 0020986
2020-04-26 19:26 anonymous Note Added: 0023937
2020-04-26 19:26 anonymous Status resolved => closed