View Issue Details

IDCategoryLast Update
0007877features2020-01-24 16:55
ReporterautopoiesisAssigned To 
Reproducibilityalways 
Status closedResolutionno change required 
PlatformAllOSAllOS VersionAll
Product Version5.12 
Fixed in Version 
Summary0007877: Always include timestamps in log viewer
DescriptionTypical "Ardour - Log" contents:

[INFO]: Output channel count configuration not supported
[INFO]: Loading bindings from C:\Program Files\Ardour5\share\ardour5\ardour.keys
harvid version: 802
[INFO]: Loading menus from C:\Program Files\Ardour5\share\ardour5\ardour.menus
[INFO]: Loading 88 MIDI patches from C:\Program Files\Ardour5\share\ardour5\patchfiles

Timestamps have not been included. If an event is worth logging, it should be timestamped; this is (very) well established good practice.
Steps To ReproduceOpen Ardour - Log window; observe the absence of timestamps :)
Additional InformationLogs without timestamps have limited value.

Please include ISO-compliant timestamps in ALL logs (on-screen/in-app/in-file...)

2020-01-18T10:52:39Z [INFO]: Loading menus from C:\Program Files\Ardour5\share\ardour5\ardour.menus

Refer to ISO 8601 for formats; consider milli- or even micro-second precision might be worthwhile.
TagsNo tags attached.

Activities

x42

2020-01-18 18:22

administrator   ~0020921

Last edited: 2020-01-18 18:23

View 2 revisions

I gave it a go in 6.0-pre0-3241-gd7801ab7ee but I'm not yet convinced:
Could you elaborate for which Ardour messages a timestamp is relevant?

> Logs without timestamps have limited value.

For system logs I do agree. For Ardour Application Warnings/Errors not so much.
It's also questionable if our target audience (musicians and audio engineers) care about ISO date.
We already got criticized for using it as default as default snapshot.

autopoiesis

2020-01-19 12:25

reporter   ~0020922

Hi x42,

Thanks for the rapid response; if it's already been discussed, tried and rejected then please close with no further action.

Cheers,
AP

x42

2020-01-20 03:47

administrator   ~0020923

Currently https://nightly.ardour.org/ builds do show ISO date/time in the log-window

It hasn't yet been discussed.
One alternative that I can think of being more useful would be showing "minutes:seconds" since Ardour was started, but I cannot make a strong case for either.

autopoiesis

2020-01-24 16:55

reporter   ~0020928

Already under discussion

Issue History

Date Modified Username Field Change
2020-01-18 11:23 autopoiesis New Issue
2020-01-18 18:22 x42 Note Added: 0020921
2020-01-18 18:23 x42 Note Edited: 0020921 View Revisions
2020-01-19 12:25 autopoiesis Note Added: 0020922
2020-01-20 03:47 x42 Note Added: 0020923
2020-01-24 16:55 autopoiesis Status new => closed
2020-01-24 16:55 autopoiesis Resolution open => no change required
2020-01-24 16:55 autopoiesis Note Added: 0020928