View Issue Details

IDCategoryLast Update
0007571bugs2018-02-22 02:23
ReportergaurangaroraAssigned To 
Reproducibilityalways 
Status feedbackResolutionopen 
PlatformLinuxOSUbuntuOS Version17.10
Product Version5.12 
Fixed in Version 
Summary0007571: 'export range' exports audio beyond session end marker as noise
DescriptionWhen exporting a range, and the out point of the range is beyond the session's end marker, a digital noise is exported instead.
Conversely, if the session's start marker is after the range in point, the audio is exported fine for that part.

Either, Ardour should warn that we are trying to export a range that is beyond the session's start-end zone, or... it should disregard the session start-end markers during a range export.
Steps To Reproduce1. Create a range shorter than the session start/end. Make sure the range out-point is after the session's end marker.
2. Export range.
 
While the range export clearly ignores the session start, the playhead stops at the session's end marker.

3. Playback the exported file. There is digital noise from the session's end marker to the range's out marker.
TagsNo tags attached.

Activities

gaurangarora

2018-02-21 08:24

reporter  

timbyr

2018-02-22 02:23

developer   ~0020166

I can't reproduce this with the official 5.12 build(linux 64-bit).

These are steps I used to reproduce:

1. Imported 6 mono stems.
2. Set up a the start/end and range markers similar to your picture
3. Right clicked on the range marker and exported the range.
4. Imported the exported range and put it between the range markers.
5. Inverted the polarity on the audio track containing exported range.
6. Brought up the Export Dialog with Session -> Export -> Export to Audiofile
7. Selected BWAV 24bit export format
8. Selected the range in the Time Span tab of the Export dialog
9. Selected "Analyze Exported Audio" checkbox and clicked on Export

In the Export Report/Analysis you should then see a very low peak value.

If you are seeing something different then please be more explicit and list the exact steps you used and if possible a simple/small Session that we can use to try and reproduce the issue. Thanks.

Issue History

Date Modified Username Field Change
2018-02-21 08:24 gaurangarora New Issue
2018-02-21 08:24 gaurangarora File Added: Screenshot from 2018-02-21 13-54-08.png
2018-02-22 02:23 timbyr Note Added: 0020166
2018-02-22 02:23 timbyr Status new => feedback