View Issue Details

IDCategoryLast Update
0007566bugs2018-02-24 01:13
ReportergregafekAssigned Totimbyr 
Reproducibilityalways 
Status resolvedResolutionno change required 
PlatformWindows 10OSOS Version
Product Version5.12 
Fixed in Version 
Summary0007566: Session "C:\Users\Greg\NAG (snapshot NAG DEMO)" did not load successfully: Failed to load state
DescriptionProgram will not open saved session. Tried backup session as well and will always get
Session "C:\Users\Greg\NAG (snapshot NAG DEMO)" did not load successfully: Failed to load state
Other sessions open correctly but not this file.
Steps To ReproduceEverytime session is opened the same message appears.
TagsNo tags attached.

Relationships

has duplicate 0007567 closed Session "C:\Users\Greg\NAG (snapshot NAG DEMO)" did not load successfully: Failed to load state 

Activities

x42

2018-02-19 20:36

administrator   ~0020159

Can you attach the session file "NAG DEMO.ardour" -- that may indicate as to why loading fails.

gregafek

2018-02-19 21:23

reporter   ~0020160

The session file was 5300k and it’s says it can only be 5000k to attach on here.is there another way to attach it here?

gregafek

2018-02-19 21:37

reporter   ~0020161

Also I changed the name from NAG DEMO to NAG to see if it would have helped,but it’s still the same file

x42

2018-02-19 21:50

administrator   ~0020162

Perhaps zipping the file can help?
Other than that, perhaps dropbox or similar cloud storage?

gregafek

2018-02-20 00:07

reporter  

NAG DEMO.zip (59,733 bytes)

gregafek

2018-02-20 00:08

reporter   ~0020163

Ok I zipped that file

gregafek

2018-02-20 17:56

reporter   ~0020165

Any leads on that yet?

timbyr

2018-02-22 02:51

developer   ~0020167

The file you have attached seems to be incomplete, so that is why it fails to load.

I'm not sure how or why the file corruption has occurred, it is like there was some sort of failure/error while writing to the file.

As this sort of issue is not something that has been reported before it may be something specific to your system.

Are the Session files you normally work with a similar size to this one?

gregafek

2018-02-22 05:33

reporter   ~0020168

The other session files are usually smaller. I did get a blue screen crash on my computer at around the same time when working on the session. The blue screen cause was of bug code usb driver. I’m not sure this is related to the session being corrupted?

timbyr

2018-02-22 11:33

developer   ~0020169

As far as I recall, when saving the Session state file we write to a temporary file and then only rename it once writing is successful. So it should not be possible for this to occur with a blue screen crash situation AFAIK.

There are a few possibilities, but I'm hoping it is not a recurring issue on your system. Perhaps just save a few more snapshots for a while until you can be certain.

x42

2018-02-22 12:17

administrator   ~0020170

Everything after byte 1048576 (1MB exact) in the file is zero.

It seems the file was not flushed to disk correctly. Probably due to the machine crash.

x42

2018-02-22 12:19

administrator   ~0020171

Is there a .bak backup file in the session dir? that may still have a valid session.

ie "NAG DEMO.ardour.bak"

gregafek

2018-02-22 15:46

reporter   ~0020172

I do have the backup file but it doesn’t open as well.same prompts. I can upload it anyway and see what happens? Also I’m experiencing a lot of crashes with the updated ardour 5.12. Could this be related to a computer issue ?

gregafek

2018-02-22 23:59

reporter  

NAG DEMO.history.bak (25,947 bytes)

gregafek

2018-02-23 00:07

reporter  

NAGDEMO.ardour.zip (284,344 bytes)

gregafek

2018-02-23 00:08

reporter   ~0020174

I just uploaded another file
"NAGDEMO.ardour.zip"
This is the backup file

timbyr

2018-02-23 03:48

developer   ~0020176

I can successfully load your backup Session file on Windows 7(64-bit) with Ardour 5.12.

I extracted the file into C:\Users\timbyr\NAG DEMO\NAG DEMO.ardour and then opened it from the Session Setup dialog.

It appears to open correctly(apart from the missing files) with no warnings or errors.

gregafek

2018-02-23 04:31

reporter   ~0020177

That’s good news. As far as on my end,what do I need to do to open it on my computer and back into the software?

timbyr

2018-02-23 08:08

developer   ~0020178

Hopefully you should just be able to rename the NAG DEMO.ardour.bak file to NAG DEMO.ardour like I did above and it should restore the Session to the backup/older copy.

gregafek

2018-02-23 21:25

reporter   ~0020182

I renamed th file and saved it into original file folder. When I open from session startup , the file is not there. How do I render the backup file a “session” so the session startup box will recognize it?

gregafek

2018-02-23 22:09

reporter   ~0020184

I resolved the issue. I had to view file extensions in folder and then rename that way. All is working now. Thanks for all the help!

timbyr

2018-02-24 01:13

developer   ~0020185

OK, good to hear. hopefully it was a one off and will not occur again.

Issue History

Date Modified Username Field Change
2018-02-19 19:27 gregafek New Issue
2018-02-19 20:36 x42 Note Added: 0020159
2018-02-19 21:23 gregafek Note Added: 0020160
2018-02-19 21:37 gregafek Note Added: 0020161
2018-02-19 21:50 x42 Note Added: 0020162
2018-02-20 00:07 gregafek File Added: NAG DEMO.zip
2018-02-20 00:08 gregafek Note Added: 0020163
2018-02-20 01:20 timbyr Relationship added has duplicate 0007567
2018-02-20 17:56 gregafek Note Added: 0020165
2018-02-22 02:51 timbyr Note Added: 0020167
2018-02-22 02:51 timbyr Status new => feedback
2018-02-22 05:33 gregafek Note Added: 0020168
2018-02-22 05:33 gregafek Status feedback => new
2018-02-22 11:33 timbyr Note Added: 0020169
2018-02-22 12:17 x42 Note Added: 0020170
2018-02-22 12:19 x42 Note Added: 0020171
2018-02-22 15:46 gregafek Note Added: 0020172
2018-02-22 23:59 gregafek File Added: NAG DEMO.history.bak
2018-02-23 00:07 gregafek File Added: NAGDEMO.ardour.zip
2018-02-23 00:08 gregafek Note Added: 0020174
2018-02-23 03:48 timbyr Note Added: 0020176
2018-02-23 04:31 gregafek Note Added: 0020177
2018-02-23 08:08 timbyr Note Added: 0020178
2018-02-23 21:25 gregafek Note Added: 0020182
2018-02-23 22:09 gregafek Note Added: 0020184
2018-02-24 01:13 timbyr Note Added: 0020185
2018-02-24 01:13 timbyr Status new => resolved
2018-02-24 01:13 timbyr Resolution open => no change required
2018-02-24 01:13 timbyr Assigned To => timbyr