View Issue Details

IDCategoryLast Update
0007411bugs2017-07-01 03:53
ReporterribanAssigned Toovenwerks 
Reproducibilityalways 
Status resolvedResolutionfixed 
Platformi86-64OSWindowsOS Version7
Product Version5.10 
Fixed in Version 
Summary0007411: OSC sending "select" messages when not requested
DescriptionWith OSC feedback enabled "select" messages are being sent when configuration is to not send "select" messages.
Steps To ReproduceClear OSC Devices.
Send message from OSC device to Ardour: "/set_surface/0/63/179/1/0 0".
Expected result: "strip" OSC feedback messages sent by Ardour.
Actual result: "strip" and "select" OSC feedback messages sent by Ardour, e.g. "/select/name s:Chan 1".
TagsNo tags attached.

Activities

ovenwerks

2017-06-30 23:05

reporter   ~0019841

While this is by design, your expectations probably have more merit than the original design. The original design was for feedback bit 13 to control "extra" select functions such as sends, plugins, etc. The functions normally available in all strips as feedback are automatically running in select. I will rethink this.
(and probably change it)

ovenwerks

2017-07-01 03:51

reporter   ~0019848

commit a967a942d29000e217637092c1a5db506aa3a24e should fix this. Feedback[13] should turn all select on and off now.

Issue History

Date Modified Username Field Change
2017-06-30 08:06 riban New Issue
2017-06-30 23:05 ovenwerks Note Added: 0019841
2017-07-01 03:51 ovenwerks Note Added: 0019848
2017-07-01 03:51 ovenwerks Status new => resolved
2017-07-01 03:51 ovenwerks Resolution open => fixed
2017-07-01 03:51 ovenwerks Assigned To => ovenwerks