View Issue Details

IDCategoryLast Update
0007291bugs2019-09-06 22:32
Reporterm4l3zAssigned Tox42 
Reproducibilityalways 
Status closedResolutionwon't fix 
PlatformUbuntuOSLinux MintOS Version18.1
Product Version5.8 
Fixed in Version 
Summary0007291: No GUI for the plugins samplv1, drumkv1
DescriptionThose are the only plugins in my collection for which I'm not able to show their GUI. They still work tho, I'm able to use the generic ardour controls editor.
Those plugins work fine in standalone and under the hosts Carla and Qtractor.
Ardour log returns : [ERROR]: failed to instantiate LV2 GUI
everytime I try to fire up the GUI.
They are qt-based (Qt version 5.5.1.) .
The version of the plugins is 0.8.0 and have been installed with apt through the KXStudio repository. They were working fine under ardour in the previous versions.
Steps To Reproduce1) Get the packages samplv1 samplv1-lv2 drumkv1 drumkv1-lv2 from the Kxstudio repository
2) Create a new MIDI track or AUDIO + MIDI track with one of those plugins.
3) Try to fire up the GUI or see if it's automatically opens.
Additional InformationThanks for the all the work !
Have a great day
TagsNo tags attached.

Activities

x42

2017-03-12 16:19

administrator   ~0019528

This sounds like a QT4/QT5 issue.

Where did you get Ardour from?
Since version 5.8, binaries from ardour.org do include libsuil which can load qt4 and qt5 GUIs.

I have not tested KXStudio, but the QT5 vee-one plugins work here on debian with official Ardour builds.

m4l3z

2017-03-12 22:28

reporter   ~0019529

Thanks for the answer.

I installed ardour through the KXStudio repository.
I think you are right about libsuil but the package is already installed on my computer. When running ardour from command line, this line appears when I try to fire up the GUI :
suil error: Unable to open wrap module /opt/ardour/lib/libsuil_qt5_in_gtk2.so (/usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.7' not found (required by /opt/ardour/lib/libsuil_qt5_in_gtk2.so))
I then noticed that my version of Qt was 5.5 so I installed Qt 5.7 from the official site but it didnt change anything.

marado

2019-03-03 21:51

reporter   ~0020605

You might be bumping into this issue: https://www.rncbc.org/drupal/node/1918#ardour

ahms

2019-09-06 21:39

reporter   ~0020770

Here on debian buster 10(64-bit), the suil version is "0.10.0~dfsg0-1" (apt-cache policy libsuil-0-0:amd64)

I ran the latest ardour nightly today, and am trying the stocked samplv1-lv2 release 0.8.6-1.

I tested the plugin with qtractor(0.9.5-1) and it runs samplv1-lv2 without any issue..

I spoke to the upstream author of samplv1 and he told me to report this to ardour as the problem is not the libraries..

Tested in other DAWS and this plugin works, but not in Ardour specifically..

Must be something in Ardour's nightly build..

Here I get this output instead of the above (and I'm running on a QT desktop -- but I also get the same error on MATE) ,
"
/opt/Ardour-6.0.pre0.2344/bin/ardour6
suil error: Unable to open UI library /usr/lib/lv2/samplv1.lv2/samplv1_ui.so (/usr/lib/x86_64-linux-gnu/libQt5Gui.so.5: undefined symbol: hb_font_funcs_set_nominal_glyph_func)
"

I looked at marado's suggestion, and that made no difference,
 https://www.rncbc.org/drupal/node/1918#ardour

there's a line with
"lv2ui:ui samplv1_lv2:ui, samplv1_lv2:ui_external ;"

and I changed this to
"lv2ui:ui samplv1_lv2:ui_x11, samplv1_lv2:ui_external ;"

but I still get the same error..

So it works with other DAWs but nor ardour...

ahms

2019-09-06 21:41

reporter   ~0020771

the problem occurs when I double-click on the samplv1 plugin button -- the plugin could be added to the track and shows the green led,

but when a user tries to open the interface it crashes taking ardour with it.

x42

2019-09-06 22:32

administrator   ~0020772

Known issue and won't fix. Arodur will drop support for all plugins that are not self-contained and depend on external libraries.
some background and explanation: http://lists.ardour.org/pipermail/ardour-users-ardour.org/2018-November/028948.html

The issue at hand is that the plugin relies on a system-wide installed library (libQt5Gui.so.5) wihch in turn needs other libraries, some of which conflict with Ardour.
There are ways to work around this but you're on your own then. It's not reasonable to expect plugins which are not self-contained to work reliably.

Issue History

Date Modified Username Field Change
2017-03-12 09:37 m4l3z New Issue
2017-03-12 16:19 x42 Note Added: 0019528
2017-03-12 22:28 m4l3z Note Added: 0019529
2019-03-03 21:51 marado Note Added: 0020605
2019-09-06 21:39 ahms Note Added: 0020770
2019-09-06 21:41 ahms Note Added: 0020771
2019-09-06 22:32 x42 Note Added: 0020772
2019-09-06 22:32 x42 Assigned To => x42
2019-09-06 22:32 x42 Status new => closed
2019-09-06 22:32 x42 Resolution open => won't fix