View Issue Details

IDProjectCategoryView StatusLast Update
0007248ardourbugspublic2017-03-04 10:15
Reportersmondet Assigned To 
Status confirmedResolutionopen 
PlatformUbuntuOSLinuxOS VersionMaverick
Product Version5.8 
Summary0007248: Crash when copying a MIDI region with debug build
DescriptionI have an ardour session with many MIDI regions, one of them when I try to copy it makes ardour crash, cf. output:

ardour-5.5.290: ../libs/ardour/ ARDOUR::MidiRegion::MidiRegion(boost::shared_ptr<const ARDOUR::MidiRegion>, ARDOUR::MusicFrame): Assertion `_name.val().find("/") == string::npos' failed.

Compared to
I don't have "MIDI region copies are independent" checked.

I `git pull`ed and rebuilt, the problem still happens (only with one particular MIDI region, the others I've tried seem fine).
All the MIDI regions were created the same way, from the Ardour UI.

The incriminated region, when trying "Duplicate" also crashes ardour with the same message.

TagsNo tags attached.



2017-02-20 03:55

reporter   ~0019419

Right after submitting I found out what was special: The name of the region contained a `/`.

I removed the `/` and now it works.

The UI should prevent the user from creating wrong names; and/or the system should sanitize the names of the regions internally.


2017-02-21 11:35

administrator   ~0019424

Last edited: 2017-02-21 11:35

What was the name of the track where this happened?

We do attempt to sanitize region and track and session names, btw ...


2017-02-21 12:49

reporter   ~0019425

I don't remember the actual name (sorry should have made a snapshot of the session…), I later found a couple more regions with the same problem.

The names looked like "NameOfThePart /2 Bass" or "NameOfThePart/2 RGuitar"
(the "/2" meant to mean "half-tempo" to me :) ).

> We do attempt to sanitize region and track and session names, btw ...

Sorry didn't mean to sound rude (sometimes I talk like an IETF RFC…).


2017-03-04 10:13

developer   ~0019468

Last edited: 2017-03-04 10:15

I can reproduce this with a debug build of Ardour version 5.8.54. You can still rename a MIDI region to contain a / character and then trying to copy that region results in a crash.

The 5.8 release doesn't crash as it doesn't contain the assertions that check for a slash in the MIDI region name and it doesn't seem to cause any issues. The MIDI source files seem to be renamed to remove the slash, perhaps the assertions are no longer necessary.

Issue History

Date Modified Username Field Change
2017-02-20 03:52 smondet New Issue
2017-02-20 03:55 smondet Note Added: 0019419
2017-02-21 11:35 paul Note Added: 0019424
2017-02-21 11:35 paul Note Edited: 0019424
2017-02-21 12:49 smondet Note Added: 0019425
2017-03-04 10:13 timbyr Note Added: 0019468
2017-03-04 10:14 timbyr Status new => confirmed
2017-03-04 10:14 timbyr Product Version 5.X git (version in description) => 5.8
2017-03-04 10:14 timbyr Summary Crash when copying a MIDI region => Crash when copying a MIDI region with debug build
2017-03-04 10:14 timbyr Description Updated
2017-03-04 10:15 timbyr Note Edited: 0019468