View Issue Details

IDCategoryLast Update
0007232bugs2020-04-19 20:18
ReporterrghvdbergAssigned Topaul 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformLinuxOSMintOS Version18
Product Version5.X git (version in description) 
Fixed in Version 
Summary0007232: No audiochannels created when adding carla-patchbay or carla-rack (lv2/vst) to a midi track.
DescriptionWhen adding instruments to a midi track ardour creates audio channels.
Carla-Patchbay can be (is often?) used to load one or more instruments.
However, I found that no audio channels created when adding carla-patchbay (lv2/vst) to a midi track.

Workaround is to click the pinout -> manual config and add the audio channels manually.
Steps To ReproduceCreate midi track
Add carla-patchbay (lv2 or vst)
Observe that no audio channels are created and thus no audio from carla
Additional InformationArdour 5.5.770
"The Plateaux of Mirror"
(rev 5.5-770-g0835309)
Intel 64-bit

tiny screenshot attached
TagsNo tags attached.

Activities

rghvdberg

2017-02-10 21:20

reporter  

Selectie_152.png (6,319 bytes)
Selectie_152.png (6,319 bytes)

x42

2017-02-10 21:27

administrator   ~0019362

Did you create the MIDI track with strict-i/o (a plugin can neither add nor remove ports), if so: try flexible-i/o.

This is a setting when creating the track and can later be changed in the context menu (right click on the mixer strip header)

x42

2017-02-10 21:30

administrator   ~0019363

PS. one exception to strict-i/o are MIDI instruments (if they announce themselves as instruments -- or for plugin standards without categorization: plugins that have 1 midi in, 0 audio inputs, >= 1 audio out)

see http://manual.ardour.org/signal-routing/signal-flow/

rghvdberg

2017-02-12 09:08

reporter   ~0019367

flexible-i/o did the trick !

Thanks

I guess this one can be closed ?

paul

2017-02-12 11:03

administrator   ~0019369

see notes. reporter can close.

system

2020-04-19 20:18

developer   ~0023716

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2017-02-10 21:20 rghvdberg New Issue
2017-02-10 21:20 rghvdberg File Added: Selectie_152.png
2017-02-10 21:27 x42 Note Added: 0019362
2017-02-10 21:30 x42 Note Added: 0019363
2017-02-12 09:08 rghvdberg Note Added: 0019367
2017-02-12 11:03 paul Note Added: 0019369
2017-02-12 11:03 paul Status new => resolved
2017-02-12 11:03 paul Resolution open => fixed
2017-02-12 11:03 paul Assigned To => paul
2020-04-19 20:18 system Note Added: 0023716
2020-04-19 20:18 system Status resolved => closed