View Issue Details

IDCategoryLast Update
0007178bugs2020-04-17 21:26
Reportermc888Assigned To 
Reproducibilityalways 
Status closedResolutionno change required 
PlatformkxstudioOSubutu 14.04.5 low latencyOS Version
Product Version5.5 
Fixed in Version 
Summary0007178: "Stop at end of session" doesn't work when recording
Description"Stop at end of session" is enabled but doesn't stop when recording. Only works on playback.
Steps To ReproduceMake sure you have an existing end marker, then record a take. Transport continues past end of session and must be stopped manually.
Additional InformationThis has not worked since Ardour 3. Duplicated problem on every git build and release version since then.
TagsNo tags attached.

Activities

BenLoftis

2016-12-19 18:42

developer   ~0019174

I consider this a feature, not a bug.

In the majority of cases you would not want the recording to stop, and be truncated, just because you hit the end marker. Especially if the End marker was set automatically by the previous recording pass. (which is how it works, normally).

If you have a technical reason where you -must- stop on the End marker, a Lua script could do that.

paul

2016-12-19 21:24

administrator   ~0019176

I also consider this to be a feature, not a bug.

If you want to stop somewhere, just set the punch range appropriately, and only engage "Punch Out".

mc888

2016-12-29 05:04

reporter   ~0019232

Ah, ok. I understand what you're saying, even if it's a feature I don't use.

Just happens to be very inconvenient for me when I'm running back and forth across a room with a bass strapped around my neck. What I need is a one-button stompbox to send start/stop hands-free...

but I think Paul nailed it with the punch range suggestion. I'll give that a go.

Thanks guys

mc888

2020-04-17 21:26

reporter   ~0021380

cleanup old tickets

Issue History

Date Modified Username Field Change
2016-12-14 00:08 mc888 New Issue
2016-12-19 18:42 BenLoftis Note Added: 0019174
2016-12-19 21:24 paul Note Added: 0019176
2016-12-29 05:04 mc888 Note Added: 0019232
2020-04-17 21:26 mc888 Status new => closed
2020-04-17 21:26 mc888 Resolution open => no change required
2020-04-17 21:26 mc888 Note Added: 0021380