View Issue Details

IDCategoryLast Update
0007161features2020-04-19 20:18
Reporter.onkel.Assigned Toovenwerks 
Reproducibilityhave not tried 
Status closedResolutionfixed 
Product Version5.5 
Fixed in Version 
Summary0007161: OSC route observer for solo lock and solo isolate
DescriptionPlease add route OSC observers for solo lock and isolate switches.
TagsNo tags attached.

Activities

.onkel.

2016-12-06 09:21

reporter  

route_observer_solo_iso_lock.patch (1,579 bytes)
diff --git a/libs/surfaces/osc/osc_route_observer.cc b/libs/surfaces/osc/osc_route_observer.cc
index e22444e..1d9ac5a 100644
--- a/libs/surfaces/osc/osc_route_observer.cc
+++ b/libs/surfaces/osc/osc_route_observer.cc
@@ -24,7 +24,7 @@
 #include "ardour/monitor_control.h"
 #include "ardour/dB.h"
 #include "ardour/meter.h"
-
+#include "ardour/solo_isolate_control.h"
 #include "osc.h"
 #include "osc_route_observer.h"
 
@@ -53,6 +53,12 @@
 		_strip->solo_control()->Changed.connect (strip_connections, MISSING_INVALIDATOR, bind (&OSCRouteObserver::send_change_message, this, X_("/strip/solo"), _strip->solo_control()), OSC::instance());
 		send_change_message ("/strip/solo", _strip->solo_control());
 
+		_strip->solo_isolate_control()->Changed.connect (strip_connections, MISSING_INVALIDATOR, bind (&OSCRouteObserver::send_change_message, this, X_("/strip/solo_iso"), _strip->solo_isolate_control()), OSC::instance());
+		send_change_message ("/strip/solo_iso", _strip->solo_isolate_control());
+		
+		_strip->solo_safe_control()->Changed.connect (strip_connections, MISSING_INVALIDATOR, bind (&OSCRouteObserver::send_change_message, this, X_("/strip/solo_safe"), _strip->solo_safe_control()), OSC::instance());
+		send_change_message ("/strip/solo_safe", _strip->solo_safe_control());
+		
 		boost::shared_ptr<Track> track = boost::dynamic_pointer_cast<Track> (_strip);
 		if (track) {
 			track->monitoring_control()->Changed.connect (strip_connections, MISSING_INVALIDATOR, bind (&OSCRouteObserver::send_monitor_status, this, track->monitoring_control()), OSC::instance());

.onkel.

2016-12-06 09:22

reporter   ~0019126

I've attached a patch file which contains my implementation.

ovenwerks

2017-07-01 18:52

reporter   ~0019857

I have effectively added your patch manually and tested it. As requested it is feedback only, the two controls can still only be set on the selected route.

system

2020-04-19 20:18

developer   ~0023691

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-12-05 11:21 .onkel. New Issue
2016-12-06 09:21 .onkel. File Added: route_observer_solo_iso_lock.patch
2016-12-06 09:22 .onkel. Note Added: 0019126
2017-07-01 18:52 ovenwerks Note Added: 0019857
2017-07-01 18:52 ovenwerks Status new => resolved
2017-07-01 18:52 ovenwerks Resolution open => fixed
2017-07-01 18:52 ovenwerks Assigned To => ovenwerks
2020-04-19 20:18 system Note Added: 0023691
2020-04-19 20:18 system Status resolved => closed