View Issue Details

IDCategoryLast Update
0007149bugs2017-01-05 13:21
ReporterrobscoAssigned Totimbyr 
Reproducibilityalways 
Status resolvedResolutionfixed 
Product Version5.X git (version in description) 
Fixed in Version5.X git (version in description) 
Summary0007149: Duplicating tracks and selecting any option (copy, new empty or share) = only the currently active playlist being reproduced.
DescriptionArdour 5.4.463
"In a Land of Clear Colours"
(rev 5.4-470-ge9eea8d)
Intel 64-bit
Steps To ReproduceDuplicating tracks and selecting any of the three options (copy, new empty or share) results in only the currently active playlist being reproduced on the new, duplicated track.

For example, 2 playlists on track one. Duplicate track one with "copy playlists" and the resulting duplicated track only has one copied playlist; the currently active one on track one.
TagsNo tags attached.

Activities

robsco

2016-11-28 03:37

reporter  

duplicate_multiple_playlists.mkv (1,318,782 bytes)

timbyr

2016-11-28 03:56

developer   ~0019076

I can confirm this issue with Ardour version 5.4.470

timbyr

2016-12-06 06:47

developer   ~0019120

Last edited: 2016-12-06 06:48

View 2 revisions

There was a discussion on IRC and this behaviour of only copying the "active" playlist is intentional.

The issue is with the ambivalent wording in the dialog.

There was some consensus that changing the dialog to say:

For each Track:

[X] Copy Playlist
[ ] New Playlist
[ ] Share Playlist with original Track

That it would be clear what was intended.

timbyr

2017-01-05 13:21

developer   ~0019266

This should now be resolved with changes to the Duplicate Track dialog in commit 05c2e4ef or nightly build >= 5.5.409

Issue History

Date Modified Username Field Change
2016-11-28 03:37 robsco New Issue
2016-11-28 03:37 robsco File Added: duplicate_multiple_playlists.mkv
2016-11-28 03:56 timbyr Note Added: 0019076
2016-11-28 03:56 timbyr Status new => confirmed
2016-12-06 06:47 timbyr Note Added: 0019120
2016-12-06 06:48 timbyr Note Edited: 0019120 View Revisions
2017-01-05 13:21 timbyr Note Added: 0019266
2017-01-05 13:21 timbyr Status confirmed => resolved
2017-01-05 13:21 timbyr Fixed in Version => 5.X git (version in description)
2017-01-05 13:21 timbyr Resolution open => fixed
2017-01-05 13:21 timbyr Assigned To => timbyr