View Issue Details

IDCategoryLast Update
0007117bugs2020-04-19 20:18
ReportermagnetophonAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformlinuxOSNixOSOS Version16.09
Product Version5.4 
Fixed in Version 
Summary0007117: can't create tracks from template with a-compressor
DescriptionWhen I try to create tracks from a template with an a-compressor, I get:


Failed to register port "Sidechain 5/audio_in 1", reason is unknown from here
Steps To Reproducecreate new session
create a track with an a-compressor
make a template of that track
create a track with that template

does not create a track, but gives the above error.
TagsNo tags attached.

Activities

timbyr

2016-11-17 12:05

developer   ~0018980

I can confirm this issue (I think) with 5.4 and 5.4.357.

I spent some time trying to reproduce with Session templates but after a bit of head scratching I can reproduce a similar (maybe the same) issue:

1. Add a a-comp plugin to an existing track
2. Select the track in Mixer or Editor
3. Select Track -> Duplicate Track/Busses MenuItem and click OK

At that point it brings up an dialog with the error "1 or more tracks/busses could not be duplicated"

and in the log window the error:

[ERROR]: AlsaBackend::register_port: Port already exists: (ardour:Sidechain 2/audio_in 1)
[ERROR]: unable to create port: failed constructor

Is this what you are doing in your "Steps to reproduce" above?

x42

2016-11-17 15:32

administrator   ~0018981

fixed in Ardour 5.4-379-gcbd1a25

system

2020-04-19 20:18

developer   ~0023675

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-11-16 17:54 magnetophon New Issue
2016-11-17 12:05 timbyr Note Added: 0018980
2016-11-17 12:05 timbyr Status new => confirmed
2016-11-17 15:32 x42 Note Added: 0018981
2016-11-17 15:32 x42 Status confirmed => resolved
2016-11-17 15:32 x42 Resolution open => fixed
2016-11-17 15:32 x42 Assigned To => x42
2020-04-19 20:18 system Note Added: 0023675
2020-04-19 20:18 system Status resolved => closed