View Issue Details

IDCategoryLast Update
0007100bugs2020-04-17 21:21
Reportermc888Assigned To 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformkxstudioOSubuntu 14.04.5OS Version
Product Version5.4 
Fixed in Version 
Summary0007100: tempo map BBT errors
Descriptionnumerous tempo map errors in log -

[WARNING]: tempo map asked for BBT time at frame -256

the frame number will always be negative and match the JACK buffer size

under some conditions (not sure how, but more than once) this error will continue to spam the log and be disruptive to jack transport
Steps To Reproducestart ardour to get the simple version, which subsides after viewing log. not sure how I managed to get it mad. but once it gets going it's a show-stopper.
Additional Informationtempo is set to constant, not ramped.

for some strange reason, the default setting was ramped and I had to change my session back to normal.
TagsNo tags attached.

Activities

nick_m

2016-11-08 10:41

reporter   ~0018927

Hi.

I wonder if you could attach a simple session that does this?

thanks for the report.

mc888

2016-11-27 19:35

reporter   ~0019063

issue still exists and has gotten worse in later versions. tested in 5.4.317 and 5.4.462.

log fills with BBT errors at session open. viewing log changes LED status from red to yellow; errors continue to spam log under yellow state.

new observation - errors stop once transport is rolling. open log viewer while transport is rolling and alarm will stay off until transport is stopped.

when transport is stopped, alarm immediately turns yellow and BBT errors resume spamming log.

mc888

2016-11-27 19:45

reporter   ~0019064

Hi Nick, tried to create a 'simple session' for you but ran into bigger problems. Please see 7148, thanks

nick_m

2016-11-28 01:42

reporter   ~0019070

i cannot reproduce this by selecting jack sync on a new or existing session,
without any other applications running.
what else is syncing to the jack transport? is it also the transport master?

the warning indicates that the tempo map was asked for the bbt time at a negative frame,
but should really be harmless. the returned bbt time in this case is 1|1|0.

can you verify that this happens for you without any other applications using jack transport?

what other applications are synched to the transport?
what versoin of jack is this?

thanks in advance.

nick_m

2016-11-28 01:49

reporter   ~0019071

is there any way you can attach the session .ardour file which displays the problem?

mc888

2016-11-28 05:54

reporter   ~0019078

Hi, yes jack is set to master but the clock was set to internal. There's nothing slaved to it. No other synched apps.

jackd2:
  Installed: 2:1.9.11~20160620-5~trusty1
  Candidate: 2:1.9.11~20160620-5~trusty1
  Version table:
 *** 2:1.9.11~20160620-5~trusty1 0
        500 http://ppa.launchpad.net/kxstudio-debian/ubuntus/ubuntu/ trusty/main amd64 Packages

Looks like falkTX version... haven't really been keeping up on what he's doing lately, but 6/20 seems like a fairly recent update.

Got it to stop spamming by toggling back and forth between JACK and Internal. Seems like it may be related to the internal clock. After save with toggle set to JACK, restarted A5 and now it runs "normally" - I still get the startup log spam, but at least it stops banging the log.

>the tempo map was asked for the bbt time at a negative frame

could a plugin like artificial latency cause that?

Still seems kind of odd but not as urgent with the workarounds.

x42

2016-11-28 10:40

administrator   ~0019079

"could a plugin like artificial latency cause that?" -> yes.

mc888

2016-12-14 00:19

reporter   ~0019156

@ x42 - thanks.

In 5.5 it's slightly changed. Now it only happens when the playhead is all the way to the left; i.e. sample 0. I can work with that, but it happens always and continuously until the playhead is moved forward and the log viewed.

At this point my best guess is the measured latency on a channel insert. I have a couple of channels it can never measure accurately because they go to an external app. So it defaults to the jack buffer size and sets up latency compensation for a full buffer.

It would be nice to be able to disable the latency compensation on these inserts. It will never work, and I don't want the compensation putting audio data in the wrong place.

jumase

2020-04-01 02:55

reporter   ~0021122

Hi, I think I've probably found how to reproduce this bug (if it could be called a bug). I've been experiencing it once in a while, but wasn't able to reproduce it. Now I've found the way, and it also happens with Ardour-6.0.pre1.68.

Steps to reproduce:

1. add a mono plugin to a stereo track/bus. It could even be the master bus. I tried some mono plugins and it occurs every time.

The thing is that Ardour duplicates the plugin: "This plugin has been replicated 2 times". Maybe, there is something weird in that process.

paul

2020-04-01 14:22

administrator   ~0021124

which plugins are you using to generate the error?

jumase

2020-04-01 20:43

reporter   ~0021127

Fisrt of all I forgot to mention the critical step to get the error. As mc888 said, it only occurs when playing from time 00:00:00:00. So play from zero time to get the error/warnings.

I did deeper testing and found that it's not related to mono or stereo plugins. Instead, it may have to do with LV1 or LV2 plugins. The strange thing is that with Ardour-6.0.pre1.78-x86_64-gcc4 version, the error is not there, but it freezes on exit and give me a warning while installing:
"Ardour was compiled with gcc4, your system uses a newer version of the standard c++ library. Plugins on your system may not load or plugin-UIs may cause crashes."
gcc --version
gcc (Debian 8.3.0-6) 8.3.0
I've also tested the last nightly build Ardour-6.0.pre1.78-dbg-x86_64-gcc5 and the problem is still there. On version 5.12 the bug is not reproducible by this method, though I did experienced it once or twice, as I said in my previous note (I'm not sure if that happened with version 5.12).

Details about plugins:

LV2 plugins tested that produces the error/warnings:
a-Compressor (mono and stereo), a-EQ, a-Expander, Calf Compressor, ZamAutoSat, CS Chorus 1 (David Robillard), GxAutoWah, Dyno-Mite Mono (Harrison Consoles), Invada Compressor, setBfree Organ Overdrive (Robin Gareus), Fast Lookahead limiter (Steve Harris), EQ10Q Mono (Pere Ràfols Soler).

The last plugin I mentioned also gives an error
"[ERROR]: failed to instantiate LV2 GUI"
The same occurs with Ardour6.0.pre1.78-gcc4 and Ardour-5.12. It works fine with the Debian repositories package.

LV1 plugins doesn't seem to affect:
Mag's Notch Filter (Alexander Ehlert), Allpass delay line (Andy Wingo), Reverse Delay (Jesse Chappell), Hard Limiter (Marcus Andersson), SC4 mono, all of them work without problem.

Let me know if there was additional information that could be useful.

x42

2020-04-01 21:17

administrator   ~0021129

"tempo map asked for sample time at bar < 1 ..." is normal under some circumstances, and only printed in debug builds.

It's usually printed when Ardour needs to inform a plugin about time (which includes music time), during pre-roll.

jumase

2020-04-01 22:04

reporter   ~0021130

Thanks x42! Now I see why it only happens when playing from zero position. I also compiled Ardour-5.x some time ago, that's why debug was available, so I got those warnings.
Thanks again for your explanation. Nothing else to say.
Regards

mc888

2020-04-17 21:21

reporter   ~0021378

closed. spam messages have not re-appeared in newer versions. open issue attracting unrelated posts.

Issue History

Date Modified Username Field Change
2016-11-08 05:19 mc888 New Issue
2016-11-08 10:41 nick_m Note Added: 0018927
2016-11-27 19:35 mc888 Note Added: 0019063
2016-11-27 19:45 mc888 Note Added: 0019064
2016-11-28 01:42 nick_m Note Added: 0019070
2016-11-28 01:49 nick_m Note Added: 0019071
2016-11-28 04:02 timbyr Status new => feedback
2016-11-28 05:54 mc888 Note Added: 0019078
2016-11-28 05:54 mc888 Status feedback => new
2016-11-28 10:40 x42 Note Added: 0019079
2016-12-14 00:19 mc888 Note Added: 0019156
2020-04-01 02:55 jumase Note Added: 0021122
2020-04-01 14:22 paul Note Added: 0021124
2020-04-01 20:43 jumase Note Added: 0021127
2020-04-01 21:17 x42 Note Added: 0021129
2020-04-01 22:04 jumase Note Added: 0021130
2020-04-17 21:21 mc888 Status new => closed
2020-04-17 21:21 mc888 Resolution open => fixed
2020-04-17 21:21 mc888 Note Added: 0021378