View Issue Details

IDCategoryLast Update
0007094bugs2020-04-19 20:18
ReporterovenwerksAssigned Toovenwerks 
Reproducibilityalways 
Status closedResolutionno change required 
Platformintel i5 PCOSLinuxOS VersionUB 1604
Product Version5.X git (version in description) 
Fixed in Version 
Summary0007094: When track is duplicated session is not marked dirty
DescriptionRight click on mixer window mixer strip for context menu. Select Duplicate...
Use this to create tracks. Click on window decoration X (or whatever the DE uses for window close). The dialog is "Quite Ardour" with yes or no... but should be:
The Session <session_name> has not been saved with an option to save, cancel or quite with no save.
TagsNo tags attached.

Activities

timbyr

2016-11-07 12:43

developer   ~0018916

I agree this is probably what should happen but Ardour currently saves the Session state whenever a new track is added/removed, so the state isn't really "dirty" in that there have not been any changes since saving(with the new track).

So you might say that this is a design choice, and changing the current behaviour would not be trivial AFAICT.

ovenwerks

2016-11-07 15:49

reporter   ~0018917

After testing:
Adding a track(s) from the track menu does not auto save it but does mark it dirty
Adding tracks from the mixer context menu does not auto save, but does mark dirty
duplicating a track does auto save

So there is a mechanism for making sure new tracks get saved but it is not consistent. I will mark this bug as invalid though. As the user will not loose work with knowing.

system

2020-04-19 20:18

developer   ~0023669

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-11-07 04:33 ovenwerks New Issue
2016-11-07 12:43 timbyr Note Added: 0018916
2016-11-07 12:43 timbyr Status new => feedback
2016-11-07 15:49 ovenwerks Note Added: 0018917
2016-11-07 15:49 ovenwerks Status feedback => new
2016-11-07 15:49 ovenwerks Status new => resolved
2016-11-07 15:49 ovenwerks Resolution open => no change required
2016-11-07 15:49 ovenwerks Assigned To => ovenwerks
2020-04-19 20:18 system Note Added: 0023669
2020-04-19 20:18 system Status resolved => closed