View Issue Details

IDCategoryLast Update
0007090bugs2020-04-19 20:18
ReporterOnkelDeadAssigned Toovenwerks 
Reproducibilityalways 
Status closedResolutionfixed 
Platformx86_64OSUbuntuOS Version16.04.01
Product Version5.X git (version in description) 
Fixed in Version 
Summary0007090: OSC reply on /strip/list breaks on first audio bus with OUTPUT != "Master"
DescriptionI'm using Ardour as a digital live mixer with mono audio bus strips as stage monitor sends. To send monitor signal to the correct audio interface, I have to disconnect it from Master (FOH) and select its hardware channel (Tascam US-16x08 is in place). If I request a strip list from my android application (bank_size = 0), this bus and all strips right of it will have a rid field with 0 value.

Disconnected audio tracks still get their valid ids.

Detected with Ardour 5.4.253 fresh clone.
Former used version (5.3.xxx) did work as expected.

Steps To ReproduceCreate an Ardour session from scratch, add two audio tracks and two audio busses, disconnect the leftmost bus from Master and request a strip list via OSC (/strip/list).
Additional InformationPlease notice that disconnected audio tracks still get their valid ids.
TagsNo tags attached.

Activities

ovenwerks

2016-11-04 19:14

reporter   ~0018907

Last edited: 2016-11-04 23:05

View 2 revisions

You are quite right. I separated out "Auxes" from buses, but I need to change the default strip types to include Auxes (Aux = bus not connected to master). Fixed in commit 91c2527f5c347bc303575619821edad44c07dfa4

I should add, the old configuration may be in the session file. If you open the OSC GUI and select the factory reset preset and then clear OSC devices. Things should work. (do save the new settings :)

OnkelDead

2016-11-05 08:34

reporter   ~0018908

Perfect!
Seems the initial issue wasn't a bug.
I didn't notice this OSC setting regarding aux strip type. My android app do not care about factory or user OSC settings and requests strip types by an initial /set_surface message. Adding bit 7 (0x80) to my request did solve the issue even in the assumed defect revision.

Thanks for clarification, issue may be closed.

system

2020-04-19 20:18

developer   ~0023666

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-11-02 12:38 OnkelDead New Issue
2016-11-04 19:14 ovenwerks Note Added: 0018907
2016-11-04 19:14 ovenwerks Status new => resolved
2016-11-04 19:14 ovenwerks Resolution open => fixed
2016-11-04 19:14 ovenwerks Assigned To => ovenwerks
2016-11-04 23:05 ovenwerks Note Edited: 0018907 View Revisions
2016-11-05 08:34 OnkelDead Note Added: 0018908
2020-04-19 20:18 system Note Added: 0023666
2020-04-19 20:18 system Status resolved => closed