View Issue Details

IDCategoryLast Update
0007067bugs2020-04-19 20:18
ReportertimbyrAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
Product Version5.4 
Fixed in Version 
Summary0007067: Sessions with missing external audio source files fail to load
DescriptionReproduced using official 5.4 32bit linux version.

Steps to reproduce:

1. Create new Session
2. Import an audio file leaving the 'Copy files to Session' checkbox unticked
3. Save Session and Quit.
4. Move external audio file referenced by Session to new directory path/location
5. Load Session and select 'Skip all missing files' in Missing file dialog.

Result:
A Loading Error dialog is displayed with the error message "Session..." did not load successfully: Cannot configure audio/midi engine with session parameters

Expected Result:
Session loads and missing source files are replaced by silence.

The Session will load in version 5.3
TagsNo tags attached.

Activities

x42

2016-10-11 20:14

administrator   ~0018785

solved in Ardour 5.4-101-gfeed964

It might be easier to amend dbf86a495b8 and simply remove "must_exist = true;"
( line 149, if (Glib::path_is_absolute (_origin)) ..)

It's unclear to me under what conditions is must_exit == false with an _origin set and why the file is required to exist in that case, so I special cased the c'tor instead for SilentFileSource.

x42

2016-10-11 21:00

administrator   ~0018786

fixed for good in Ardour 5.4-103-g0b51d76

system

2020-04-19 20:18

developer   ~0023660

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-10-10 12:16 timbyr New Issue
2016-10-11 20:14 x42 Note Added: 0018785
2016-10-11 21:00 x42 Note Added: 0018786
2016-10-11 21:00 x42 Status new => resolved
2016-10-11 21:00 x42 Resolution open => fixed
2016-10-11 21:00 x42 Assigned To => x42
2020-04-19 20:18 system Note Added: 0023660
2020-04-19 20:18 system Status resolved => closed