View Issue Details

IDCategoryLast Update
0007053bugs2020-04-19 20:18
ReportertimbyrAssigned Totimbyr 
Reproducibilityalways 
Status closedResolutionfixed 
Product Version5.X git (version in description) 
Fixed in Version5.X git (version in description) 
Summary0007053: Order of Playlist XML nodes changes at first Session save
DescriptionThis causes large changes to the Session XML file the first time the Session is saved even if nothing has actually changed.

It appears this is caused by the way the playlists are stored and iterated in the SessionPlaylists class when writing Session XML state.
TagsNo tags attached.

Activities

timbyr

2016-10-03 03:04

developer   ~0018744

I've pushed a branch called 5.5-fix-playlist-state-sort to origin to fix this issue.

If any other developer wants to test, review and push the branch to master that is fine, otherwise I will do it in a few days.

timbyr

2016-10-10 01:11

developer   ~0018781

This issue should now be fixed in master branch as of revision f8a098f3 or a nightly build >= 5.4.84

system

2020-04-19 20:18

developer   ~0023658

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-10-03 03:01 timbyr New Issue
2016-10-03 03:04 timbyr Note Added: 0018744
2016-10-10 01:11 timbyr Note Added: 0018781
2016-10-10 01:11 timbyr Status new => resolved
2016-10-10 01:11 timbyr Fixed in Version => 5.X git (version in description)
2016-10-10 01:11 timbyr Resolution open => fixed
2016-10-10 01:11 timbyr Assigned To => timbyr
2020-04-19 20:18 system Note Added: 0023658
2020-04-19 20:18 system Status resolved => closed