View Issue Details

IDCategoryLast Update
0007044bugs2020-04-19 20:18
ReporterunpiruAssigned Tounpiru 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformLinuxOSUbuntu 16.04.1OS Version4.4.0-36-generic
Product Version5.3 
Fixed in Version 
Summary0007044: Crash when recording midi
DescriptionArdour 5.3 always crash when recording midi from an Akai MPX8.
Steps To Reproduce - new project
 - import or rec the attached midi file
Additional InformationStack trace:

ardour-5.3.0: ../libs/evoral/src/Sequence.cpp:319: void Evoral::Sequence<Time>::const_iterator::set_event() [with Time = Evoral::Beats]: La declaración `midi_event_is_valid(_event->buffer(), _event->size())' no se cumple.

Thread 1 "ardour-5.3.0" received signal SIGABRT, Aborted.
0x00007fffef87c418 in raise () from /lib/x86_64-linux-gnu/libc.so.6
(gdb) backtrace
#0 0x00007fffef87c418 in raise () from /lib/x86_64-linux-gnu/libc.so.6
0000001 0x00007fffef87e01a in abort () from /lib/x86_64-linux-gnu/libc.so.6
#2 0x00007fffef874bd7 in ?? () from /lib/x86_64-linux-gnu/libc.so.6
#3 0x00007fffef874c82 in __assert_fail () from /lib/x86_64-linux-gnu/libc.so.6
0000004 0x00007ffff50d74f6 in Evoral::Sequence<Evoral::Beats>::const_iterator::set_event (this=0x7fffffffd110) at ../libs/evoral/src/Sequence.cpp:319
0000005 0x00007ffff50d5955 in Evoral::Sequence<Evoral::Beats>::const_iterator::const_iterator (this=0x7fffffffd110, seq=..., t=..., force_discrete=true, filtered=
    std::set with 0 elements, active_notes=0x0) at ../libs/evoral/src/Sequence.cpp:197
#6 0x00007ffff66c8a53 in Evoral::Sequence<Evoral::Beats>::begin (this=0x786b820, t=..., force_discrete=true, f=std::set with 0 elements, active_notes=0x0)
    at /home/piru/soft/Ardour-5.3.0/libs/evoral/evoral/Sequence.hpp:278
#7 0x00007ffff66bfd4f in ARDOUR::MidiModel::sync_to_source (this=0x786b6f0, source_lock=...) at ../libs/ardour/midi_model.cc:1463
0000008 0x00007ffff697e607 in ARDOUR::SMFSource::ensure_disk_file (this=0x78d58f0, lock=...) at ../libs/ardour/smf_source.cc:768
0000009 0x00007ffff697e4d2 in ARDOUR::SMFSource::flush_midi (this=0x78d58f0, lock=...) at ../libs/ardour/smf_source.cc:739
0000010 0x00007ffff66fe518 in ARDOUR::MidiSource::session_saved (this=0x78d58f0) at ../libs/ardour/midi_source.cc:466
0000011 0x00007ffff6914d0d in ARDOUR::Session::save_state (this=0x21c6760, snapshot_name="bugreport", pending=false, switch_to_snapshot=false, template_only=false)
    at ../libs/ardour/session_state.cc:802
0000012 0x0000000000701b84 in ARDOUR_UI::save_session_at_its_request (this=0x1aaba70, snapshot_name="bugreport") at ../gtk2_ardour/ardour_ui.cc:863
0000013 0x000000000075cfe1 in boost::_mfi::mf1<void, ARDOUR_UI, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > >::operator() (
    this=0x7fff90107908, p=0x1aaba70, a1="bugreport") at /usr/include/boost/bind/mem_fn_template.hpp:165
0000014 0x00000000007532e8 in boost::_bi::list2<boost::_bi::value<ARDOUR_UI*>, boost::arg<1> >::operator()<boost::_mfi::mf1<void, ARDOUR_UI, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > >, boost::_bi::list1<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&> > (
    this=0x7fff90107918, f=..., a=...) at /usr/include/boost/bind/bind.hpp:313
TagsNo tags attached.

Activities

unpiru

2016-09-27 01:26

reporter  

bug.midi (88 bytes)

unpiru

2016-09-27 01:27

reporter  

import-stack.txt (3,750 bytes)
ardour-5.3.0: ../libs/evoral/src/Sequence.cpp:319: void Evoral::Sequence<Time>::const_iterator::set_event() [with Time = Evoral::Beats]: La declaración `midi_event_is_valid(_event->buffer(), _event->size())' no se cumple.

Thread 26 "ardour-5.3.0" received signal SIGABRT, Aborted.
[Cambiando a Thread 0x7fffb83ed800 (LWP 7377)]
0x00007fffef87c418 in raise () from /lib/x86_64-linux-gnu/libc.so.6
(gdb) backtrace
#0  0x00007fffef87c418 in raise () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007fffef87e01a in abort () from /lib/x86_64-linux-gnu/libc.so.6
#2  0x00007fffef874bd7 in ?? () from /lib/x86_64-linux-gnu/libc.so.6
#3  0x00007fffef874c82 in __assert_fail () from /lib/x86_64-linux-gnu/libc.so.6
#4  0x00007ffff50d74f6 in Evoral::Sequence<Evoral::Beats>::const_iterator::set_event (this=0x7fffb83eba10) at ../libs/evoral/src/Sequence.cpp:319
#5  0x00007ffff50d5955 in Evoral::Sequence<Evoral::Beats>::const_iterator::const_iterator (this=0x7fffb83eba10, seq=..., t=..., force_discrete=false, filtered=
    std::set with 0 elements, active_notes=0x0) at ../libs/evoral/src/Sequence.cpp:197
#6  0x00007ffff66c8a53 in Evoral::Sequence<Evoral::Beats>::begin (this=0x82d4230, t=..., force_discrete=false, f=std::set with 0 elements, active_notes=0x0)
    at /home/piru/soft/Ardour-5.3.0/libs/evoral/evoral/Sequence.hpp:278
#7  0x00007ffff66fcba5 in ARDOUR::MidiSource::midi_read (this=0x27d02d0, lm=..., dst=..., source_start=0, start=0, cnt=47999, tracker=0x7fff93ae6930, filter=0x0, 
    filtered=std::set with 0 elements, beat=0, start_beat=0) at ../libs/ardour/midi_source.cc:252
#8  0x00007ffff66ec548 in ARDOUR::MidiRegion::_read_at (this=0x7fff900fc810, dst=..., position=0, dur=47999, chan_n=0, mode=ARDOUR::Sustained, tracker=0x7fff93ae6930, 
    filter=0x0) at ../libs/ardour/midi_region.cc:391
#9  0x00007ffff66ec1de in ARDOUR::MidiRegion::read_at (this=0x7fff900fc810, out=..., position=0, dur=47999, chan_n=0, mode=ARDOUR::Sustained, tracker=0x7fff93ae6930, 
    filter=0x0) at ../libs/ardour/midi_region.cc:328
#10 0x00007ffff66e16df in ARDOUR::MidiPlaylist::read (this=0x65ab630, dst=..., start=0, dur=47999, chan_n=0, filter=0x0) at ../libs/ardour/midi_playlist.cc:193
#11 0x00007ffff66ad270 in ARDOUR::MidiDiskstream::read (this=0x658a580, start=@0x658aa98: 0, dur=47999, reversed=false) at ../libs/ardour/midi_diskstream.cc:751
#12 0x00007ffff66ad641 in ARDOUR::MidiDiskstream::do_refill (this=0x658a580) at ../libs/ardour/midi_diskstream.cc:830
#13 0x00007ffff66ad488 in ARDOUR::MidiDiskstream::_do_refill_with_alloc (this=0x658a580) at ../libs/ardour/midi_diskstream.cc:788
#14 0x00007ffff63446b8 in ARDOUR::Diskstream::do_refill_with_alloc (this=0x658a580, partial_fill=true)
    at /home/piru/soft/Ardour-5.3.0/libs/ardour/ardour/diskstream.h:181
#15 0x00007ffff66acecc in ARDOUR::MidiDiskstream::seek (this=0x658a580, frame=0, complete_refill=true) at ../libs/ardour/midi_diskstream.cc:676
#16 0x00007ffff63bd01e in ARDOUR::Auditioner::audition_region (this=0x6525630, region=...) at ../libs/ardour/auditioner.cc:489
#17 0x00007ffff688a05f in ARDOUR::Session::non_realtime_set_audition (this=0x21d35a0) at ../libs/ardour/session.cc:5369
#18 0x00007ffff696641b in ARDOUR::Session::butler_transport_work (this=0x21d35a0) at ../libs/ardour/session_transport.cc:465
#19 0x00007ffff63f25a6 in ARDOUR::Butler::thread_work (this=0x21c2ee0) at ../libs/ardour/butler.cc:208
#20 0x00007ffff63f1e6a in ARDOUR::Butler::_thread_work (arg=0x21c2ee0) at ../libs/ardour/butler.cc:156
#21 0x00007ffff4b4365b in fake_thread_start (arg=0x65237c0) at ../libs/pbd/pthread_utils.cc:101
#22 0x00007ffff0fc76fa in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#23 0x00007fffef94db5d in clone () from /lib/x86_64-linux-gnu/libc.so.6
import-stack.txt (3,750 bytes)

unpiru

2016-09-27 01:27

reporter  

recording-stack.txt (2,785 bytes)
ardour-5.3.0: ../libs/evoral/src/Sequence.cpp:319: void Evoral::Sequence<Time>::const_iterator::set_event() [with Time = Evoral::Beats]: La declaración `midi_event_is_valid(_event->buffer(), _event->size())' no se cumple.

Thread 1 "ardour-5.3.0" received signal SIGABRT, Aborted.
0x00007fffef87c418 in raise () from /lib/x86_64-linux-gnu/libc.so.6
(gdb) backtrace
#0  0x00007fffef87c418 in raise () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007fffef87e01a in abort () from /lib/x86_64-linux-gnu/libc.so.6
#2  0x00007fffef874bd7 in ?? () from /lib/x86_64-linux-gnu/libc.so.6
#3  0x00007fffef874c82 in __assert_fail () from /lib/x86_64-linux-gnu/libc.so.6
#4  0x00007ffff50d74f6 in Evoral::Sequence<Evoral::Beats>::const_iterator::set_event (this=0x7fffffffd110) at ../libs/evoral/src/Sequence.cpp:319
#5  0x00007ffff50d5955 in Evoral::Sequence<Evoral::Beats>::const_iterator::const_iterator (this=0x7fffffffd110, seq=..., t=..., force_discrete=true, filtered=
    std::set with 0 elements, active_notes=0x0) at ../libs/evoral/src/Sequence.cpp:197
#6  0x00007ffff66c8a53 in Evoral::Sequence<Evoral::Beats>::begin (this=0x786b820, t=..., force_discrete=true, f=std::set with 0 elements, active_notes=0x0)
    at /home/piru/soft/Ardour-5.3.0/libs/evoral/evoral/Sequence.hpp:278
#7  0x00007ffff66bfd4f in ARDOUR::MidiModel::sync_to_source (this=0x786b6f0, source_lock=...) at ../libs/ardour/midi_model.cc:1463
#8  0x00007ffff697e607 in ARDOUR::SMFSource::ensure_disk_file (this=0x78d58f0, lock=...) at ../libs/ardour/smf_source.cc:768
#9  0x00007ffff697e4d2 in ARDOUR::SMFSource::flush_midi (this=0x78d58f0, lock=...) at ../libs/ardour/smf_source.cc:739
#10 0x00007ffff66fe518 in ARDOUR::MidiSource::session_saved (this=0x78d58f0) at ../libs/ardour/midi_source.cc:466
#11 0x00007ffff6914d0d in ARDOUR::Session::save_state (this=0x21c6760, snapshot_name="bugreport", pending=false, switch_to_snapshot=false, template_only=false)
    at ../libs/ardour/session_state.cc:802
#12 0x0000000000701b84 in ARDOUR_UI::save_session_at_its_request (this=0x1aaba70, snapshot_name="bugreport") at ../gtk2_ardour/ardour_ui.cc:863
#13 0x000000000075cfe1 in boost::_mfi::mf1<void, ARDOUR_UI, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > >::operator() (
    this=0x7fff90107908, p=0x1aaba70, a1="bugreport") at /usr/include/boost/bind/mem_fn_template.hpp:165
#14 0x00000000007532e8 in boost::_bi::list2<boost::_bi::value<ARDOUR_UI*>, boost::arg<1> >::operator()<boost::_mfi::mf1<void, ARDOUR_UI, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > >, boost::_bi::list1<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&> > (
    this=0x7fff90107918, f=..., a=...) at /usr/include/boost/bind/bind.hpp:313
recording-stack.txt (2,785 bytes)

unpiru

2016-09-27 01:49

reporter  

kmidimon output.png (82,439 bytes)
kmidimon output.png (82,439 bytes)

paul

2016-09-29 13:33

administrator   ~0018725

at the time of this bug report, polyphonic pressure was known not to work. fix will be forthcoming.

timbyr

2016-12-21 04:42

developer   ~0019204

This issue should now be resolved in version 5.5

Please confirm if you can, otherwise I will mark this issue as resolved soon.

unpiru

2016-12-27 11:04

reporter   ~0019220

Works fine, thanks!

system

2020-04-19 20:18

developer   ~0023655

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-09-27 01:26 unpiru New Issue
2016-09-27 01:26 unpiru File Added: bug.midi
2016-09-27 01:27 unpiru File Added: import-stack.txt
2016-09-27 01:27 unpiru File Added: recording-stack.txt
2016-09-27 01:49 unpiru File Added: kmidimon output.png
2016-09-29 13:33 paul Note Added: 0018725
2016-12-21 04:42 timbyr Note Added: 0019204
2016-12-21 04:42 timbyr Status new => feedback
2016-12-27 11:04 unpiru Note Added: 0019220
2016-12-27 11:04 unpiru Status feedback => new
2016-12-27 11:05 unpiru Status new => resolved
2016-12-27 11:05 unpiru Resolution open => fixed
2016-12-27 11:05 unpiru Assigned To => unpiru
2020-04-19 20:18 system Note Added: 0023655
2020-04-19 20:18 system Status resolved => closed