View Issue Details

IDProjectCategoryView StatusLast Update
0007028ardourbugspublic2016-09-15 21:47
Reporternstewart Assigned To 
Status newResolutionopen 
Platformx86OSUbuntu Studio OS Version16.04
Product Version5.X git (version in description) 
Summary0007028: stale lua scripts saved in session
Descriptiongit 77bd398153240390362fea83533627e6d767ddb3

Lua scripts added/removed with the script manager do not pick up changes, even when removed and re-added.
Steps To ReproducePull up Script Manager.
Add/Set -> Add Scopes (pick a script)
Call - observe output

Modify script.
Remove script from script manager.
Re-add script in script manager.
Call script. (did not reflect changes)
Open script inside Ardour's Scripting window, observe changes do not reflect current filesystem state of modified script
TagsNo tags attached.



2016-09-15 08:33

administrator   ~0018643

I cannot reproduce.

addscopes.lua should be read-only. I guess there's a copy in Ardour's search path: two scripts with the same {name = ""} in the script header but different file-names.

Try changing the "name" = "xxx" in the script.

Edit > Scripting > Script Manager > Refresh -- and see if a script with the old name still exists.

Can you elaborate a bit? How do you "modify script"? Do you use an external editor or save (a copy) with Window > Scripting?

Where do save it to? Do you run Ardour from the source-dir or a installed version? Is there perhaps have a system-wide script-dir which trumps local modified files?

Possible script dirs (depending on how you run ardour, or where you've got it from): <src-dir>/scripts $HOME/.config/ardour5/scripts/ /opt/Ardour-<version/scripts


2016-09-15 10:28

reporter   ~0018645

I was running them out of src-dir/scripts. Installing them elsewhere
resulted in duplicates being shown, as it still finds src-dir/scripts.
I edited with an external editor and changed the name string. Also
added print statements.


2016-09-15 10:35

administrator   ~0018646

Do you get the Same result after changing the name?

ie the name changes, but you still get the old script? if so, that'd be really odd.


2016-09-15 11:22

reporter   ~0018647

Yes to name string changed. In my case the file as it executes from ardour no longer exists on disk outside of the Ardour session.


2016-09-15 21:47

reporter   ~0018652

This appears to be restricted to scripts in the src-dir/scripts directory. If I copy to ~/.config/ardour5/scripts - they update on refresh.

Issue History

Date Modified Username Field Change
2016-09-15 03:35 nstewart New Issue
2016-09-15 08:33 x42 Note Added: 0018643
2016-09-15 10:28 nstewart Note Added: 0018645
2016-09-15 10:35 x42 Note Added: 0018646
2016-09-15 11:22 nstewart Note Added: 0018647
2016-09-15 21:47 nstewart Note Added: 0018652