View Issue Details

IDCategoryLast Update
0006997bugs2020-04-19 20:18
ReporterfaustAssigned Topaul 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformLinuxOSDebianOS VersionJessie 8.5
Product Version5.3 
Fixed in Version 
Summary0006997: Clic on "bypass" from calf plugin crashes ardour
DescriptionArdour crashes when clicking on the "bypass" button of some plugins:
- Calf compressor
- Calf equalizer

Note:
- The ardour standard bypass switch button from the mixer view or the plugin preference works well and does not crashes ardour.
- compilation commands:
$ ./waf configure
$ ./waf build -j4

Steps To Reproduce1/ Open ardour session
2/ create a track
3/ add an equalizer (CALF)
4/ click on the bypass button from the plugin preference
Additional Information$ ardour5 -D all
JackEngine::XRun: client = ardour was not finished, state = Running
JackAudioDriver::ProcessGraphAsyncMaster: Process error
Segmentation fault

This is my first bug report so:
1/ this is maybe not an ardour problem and bug may have to be open to calf plugin dev?
2/ feel free to ask more debug trace.
TagsNo tags attached.

Activities

beefheart

2016-08-30 04:25

reporter   ~0018515

I think a gdb output is usually helpful - https://ardour.org/debugging_ardour
I tried to reproduce this with ardour 5.3 (binary from ardour website) and calf git version but couldn't get the same thing to happen.

faust

2016-08-30 13:39

reporter   ~0018517

Last edited: 2016-08-30 13:52

View 2 revisions

Hi beefheart, thank you for your tests!
I confirm, with latest version of calf plugin (0.0.60), I have no more crashes.

Y was using the Debian Jessie package version (0.0.19+git20140915+5de5da28-1).

You can close this bug report.

paul

2016-08-31 10:07

administrator   ~0018520

see notes.

system

2020-04-19 20:18

developer   ~0023646

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-08-29 16:26 faust New Issue
2016-08-30 04:25 beefheart Note Added: 0018515
2016-08-30 13:39 faust Note Added: 0018517
2016-08-30 13:52 faust Note Edited: 0018517 View Revisions
2016-08-31 10:07 paul Note Added: 0018520
2016-08-31 10:07 paul Status new => resolved
2016-08-31 10:07 paul Resolution open => fixed
2016-08-31 10:07 paul Assigned To => paul
2020-04-19 20:18 system Note Added: 0023646
2020-04-19 20:18 system Status resolved => closed