View Issue Details

IDCategoryLast Update
0006980bugs2016-08-25 02:17
Reporterlgdyson3Assigned To 
Reproducibilityalways 
Status newResolutionopen 
PlatformDell Inspiron E4310 (i5)OSUbuntu StudioOS Version16.04
Product Version5.0 
Fixed in Version 
Summary0006980: Play head does not snap to correct Location Markers with Key Bindings
DescriptionRan across a strange problem in Ardour 4.6 and Ardour 5 while using Jack. The play head seems to be acting strange regarding Location Markers when Ardour is synced to Jack.

The play head (Red line on the screen with the upside down triangle on top, saying this just to be clear), which normally follows the key bindings and snaps to the Location Markers, started acting oddly.
-Selecting location 1 would seemingly do nothing.
-Selecting 2 would send the play head to location 1, and selecting 3 would send it to 2.
-Selecting 2 would then send the play head it to 3, then again to 1, but never to 2.
-Selecting random key bindings would send the play head to a seemingly random Location Marker, but never the one intended.

Also, the Home and End keys were reversed.
-The play head would go to the End, when Home was pressed and vice versa. -Unless I had just chosen one of the numbered Location Markers, in which case it would jump from one of them to another one of them (say 1 to 3), and by pressing Home or end again, the play head would then go to the opposite location (Home to End or End to Home).

So, after searching around a bit, I discovered the Session> Properties menu and found the Jack Transport/Time Settings in the Time code window and unchecked it. The location problem went away, but then Hydrogen would not sync or change tempo (as Ardour was no longer the Time Code Master). Then Transport> Time Master was checked, but this did nothing, so it was unchecked.

If the 'Enable/Disable external position sync' button was toggled back to 'Internal', the location markers worked just fine. If the Jack Transport/Time Settings were again checked to make Ardour the Time Master, Hydrogen would sync, but the location markers displayed the same odd behavior.

I then had a moment of really looking at the screen and realized two things:
1) I had not payed attention to the Primary Clock, or the Secondary Clock. And
2) I had not pressed Play after changing a location.

So, I repeated the process and discovered that when synced to Jack (with Ardour set as the Time Master) the play head would still end up in the wrong place on the time line when the Location Markers were selected with Key Bindings, but the Primary and Secondary Clocks both showed the correct intended location.

-I.E. if Location Marker 1 is set at 10 seconds and Location Marker 2 was set at 20 seconds, when pressing Location marker 2 (the first time) the play head would go to Location Marker 1 at 10 seconds, but the Primary Clock would show 00:00:20:00.

I then pressed play and the session started playing from 20 seconds. This happened with all the Location Markers and the Home and End locations as well. When using the Key Bindings or the Home and End keys, regardless of where the play head was on the screen, it would play or record from the intended location. If I used the mouse to move the play head, it worked as it should and played from that point regardless of the sync state.
Steps To ReproduceDid a clean install of Ubuntu Studio 16.04, then downloaded Ardour 5.05. Started qjackctl and changed my input and out put device to USB (Focusrite Saffire 2i2, though it behaves the same when set to 'default'), then changed my buffer to 128ms. Sample rate is set to 441000 (did not change this).

Saved the preferences, started Jack, then started a previous session of Ardour (did this in both 4.6 and 5) with one stereo track of audio. This was repeated with a different session with more audio tracks, and then with one newly recorded and the results were the same.

Added three location markers, and bound them to keys (Shift + 1, Shift + 2, Shift + 3). Tested the key bindings, and the Home and End keys. They worked fine. Played some audio, rewound, FF, and generally navigated around to make sure things worked. They did. Did not change any prefs.

Then, toggled 'Enable/Disable external position sync' button so that it went from Internal to Jack. Tried this by itself and while syncing to Hydrogen.
Additional InformationI don't know if anyone has come across this, but if you have and you have a solution, that would be great. If not, the essential function works. Bear in mind that this is my first post, so if I have missed some procedural things or posted it in the wrong place, please let me know and I will make sure to get it right next time.

Thanks.
Lloyd
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2016-08-25 02:17 lgdyson3 New Issue