View Issue Details

IDCategoryLast Update
0006976bugs2020-04-19 20:18
Reportertrebmuh-olinuxxAssigned Topaul 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformOSdebianOS Versionjessie
Product Version5.0 
Fixed in Version 
Summary0006976: Ctrl + double-click doesn't open a plugin with the generic UI, but with the plugin provided UI
DescriptionAs the tooltip when overing a plugin in the mixer strip says : double-click is supposed to open the plugin with its UI, and Ctrl + double-click is supposed to open it with the generic UI.

It doesn't work, meaning : Ctrl + double-click is opening the plugin with its self-provided UI.

Tested with various LV2 plugins such as : x42 fil4, IR.lv2, guitarix GxCompressor, ZamDelay, Calf 30 bands EQ.

Note that opening the generic UI from the context menu works as expected.
Steps To Reproduce- open Ardour
- create an audio track
- load a plugin
- Ctrl + double-click on it
Additional InformationSupposed to be working if looking at the tooltip when mouseovering the plugin in the mixer strip, as well as reading at : https://ardour.org/news/3.2.html
TagsNo tags attached.

Activities

paul

2016-08-24 02:48

administrator   ~0018468

Already fixed in git. The tooltip and code did not match; the code now matches what was said in the tooltip. commit ed5091d7ae47

trebmuh-olinuxx

2016-09-03 18:48

reporter   ~0018542

Last edited: 2016-09-03 18:48

View 2 revisions

Hi Paul,
running a backport on debian Jessie from the debian Sid 5.3 package, it doesn't looks to be here.

The_CLA mentioned on IRC :
<the_CLA_2> olinuxx: It's Alt + Double Click
<the_CLA_2> olinuxx: The tooltip seems to be wrong.
<the_CLA_2> olinuxx: Hm... just reading the bug report... So I guess it was supposed to be changed the other way round. Not sure I would like that, though. Las might be able to tell more when he's back.

So I'm putting this here to keep the momentum.

Let me know if you'd like me to test anything else.

system

2020-04-19 20:18

developer   ~0023642

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-08-22 01:17 trebmuh-olinuxx New Issue
2016-08-24 02:48 paul Note Added: 0018468
2016-08-24 02:48 paul Status new => resolved
2016-08-24 02:48 paul Resolution open => fixed
2016-08-24 02:48 paul Assigned To => paul
2016-09-03 18:48 trebmuh-olinuxx Note Added: 0018542
2016-09-03 18:48 trebmuh-olinuxx Note Edited: 0018542 View Revisions
2020-04-19 20:18 system Note Added: 0023642
2020-04-19 20:18 system Status resolved => closed