View Issue Details

IDCategoryLast Update
0006967bugs2020-04-19 20:18
ReportermhartzelAssigned Tonick_m 
Reproducibilityalways 
Status closedResolutionno change required 
PlatformIntel x86_64OSGentoo LinuxOS VersionCurrent
Product Version5.0 
Fixed in Version 
Summary0006967: Accidentally dragging on most timeline rulers messes clip positions in song
DescriptionIn Ardour 5.0.5 if you click and drag on one of these rulers: Mins + Sec, Timecode, Samples, Bars:Beats, Meter, Tempo, Location Markers it changes the tempo of the song. This is dangerous and very easy to do accidentally because one routinely moves the playhead clicking on timeline rulers. When you accidentally change tempo your song rhythm gets messed up.

In my opinion potentially destructive features like this should be enabled only when clicking with a keyboard modifier.
TagsNo tags attached.

Activities

mhartzel

2016-08-19 08:55

reporter   ~0018416

Just one more thought after messing more with the change tempo by dragging rulers feature.

If you could zoom in and out in a sessions time just by dragging on a ruler, like you can do now with the tempo, it would be a wonderfully easy and intuitive way to work and move inside a session. When you change tempo by dragging on a ruler now, think about if it was time not tempo that gets zoomed in and out. The zoom ruler could perhaps be located below the summary window and be a part of its functionality.

Sorry for mixing a bug report and a feature request in the same report :)

mhartzel

2016-08-19 10:18

reporter   ~0018417

After digging around I realize that what I'm proposing above already exists. Just drag the object border at the summary :)

timbyr

2016-08-19 10:46

developer   ~0018418

Perhaps you mean something like this: http://tracker.ardour.org/view.php?id=6768

mhartzel

2016-08-19 13:35

reporter   ~0018422

timbyr: yes :)

But now when I try to drag the border of the object in the summary window in a session with lots of regions I realize (like you say on the page linked above) that there would be serious performance issues.

For something like this to work smoothly it probably requires the feature to be implemented using 3D hardware on a graphics chip. Regions would be 2D / 3D objects and the GPU would do all the heavy lifting calculating the size of regions on the fly.

This would make a powerful 3D card a requirement for using Ardour, and I don't really want that :)

nick_m

2016-08-19 19:10

reporter   ~0018427

Last edited: 2016-08-19 19:11

View 3 revisions

I think there are two issues in this report.

You say dragging on the rulers "changes the tempo of the song".
This could indicate that the modifier keys are messed up in some way.
The drag you are describing usually needs the constraint modifier to be held
down.
Please try Preferences->User Interaction and (with a nightly, not the release)
and check that the 'recommended' modifier setting in the tooltips is followed.
It sounds like you may have something set to 'unmodified' which translates to
'always on'..
If you don't have a nightly build available, try setting the 'constrain drags using'
setting to ctrl-shift.

Another possible explanation is that when the mouse is over a meter or tempo
mark and the playhead is also over the mark, the user is unsure which will
move if they click to grab and move.

The next nightly build attempts to make the object to be moved more obvious for
tempo and meter markers.
If you hover over a tempo/meter mark, it will change colour to indicate that it
will be grabbed if you click.
If the playhead is over some part of the marker, moving the mouse over it
(the ph) will switch the marker back to its natural colour (a click will now
grab the playhead).

mhartzel

2016-08-19 20:32

reporter   ~0018428

Last edited: 2016-08-19 20:43

View 3 revisions

You are right, I have changed the constrain setting, it is:

When beginning a drag: Constrain drag using = Unmodified

It is the cause of the behaviour I described so the problem is solved :)

However I wonder if the word constrain is used to mean totally different things on different Ardour functions. It might be my not so perfect understanding of the English language (not my native language) but I thought constrain means: keep in place / limit movement/ limit freedom. It seems to me that this is what it means when you use the constrain modifier while dragging regions.

When the constrain modifier is used on the ruler while dragging it kind of means the opposite of: keep in place / limit movement, because it "frees" the tempo from it's locked down state to move freely following the mouse pointer. This is why I never would have guessed the constrain modifier played a part in this problem.

I think there should be some kind of indication (maybe a tooltip) in Ardour preferences that tells the user what are the different functions the constrain modifier affects as some settings can have very unexpected consequences like this case demonstrates :)

So the bug report can be closed since there is no bug, it was just the combination of maybe a bit unclear use of concepts (or my misunderstanding of those) and a user error :)

Thanks for your help solving this nick_m :)

nick_m

2016-08-20 01:16

reporter   ~0018431

Using the Constraint modifier on a tempo marker holds the marker in its
audio or music-locked position and alters the tempo with vertical movement.

Originally, dragging the BBT ruler was meant to move the previous audio-locked
meter, but as you have discovered it is very easy to move the music in this way.
The remnant of this is constraint-dragging the beats (BBT ruler) which holds
the previous audio-locked meter to its position and alters the previous tempo.

So that's why it is the way it is.
Having said that, i agree that the naming is not great for that purpose.

nick_m

2016-08-20 02:06

reporter   ~0018432

Submitter said the problem is solved.

system

2020-04-19 20:18

developer   ~0023640

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-08-19 07:53 mhartzel New Issue
2016-08-19 08:55 mhartzel Note Added: 0018416
2016-08-19 10:18 mhartzel Note Added: 0018417
2016-08-19 10:46 timbyr Note Added: 0018418
2016-08-19 13:35 mhartzel Note Added: 0018422
2016-08-19 19:10 nick_m Note Added: 0018427
2016-08-19 19:10 nick_m Note Edited: 0018427 View Revisions
2016-08-19 19:11 nick_m Note Edited: 0018427 View Revisions
2016-08-19 20:32 mhartzel Note Added: 0018428
2016-08-19 20:41 mhartzel Note Edited: 0018428 View Revisions
2016-08-19 20:43 mhartzel Note Edited: 0018428 View Revisions
2016-08-20 01:16 nick_m Note Added: 0018431
2016-08-20 02:06 nick_m Note Added: 0018432
2016-08-20 02:06 nick_m Status new => resolved
2016-08-20 02:06 nick_m Resolution open => no change required
2016-08-20 02:06 nick_m Assigned To => nick_m
2020-04-19 20:18 system Note Added: 0023640
2020-04-19 20:18 system Status resolved => closed