View Issue Details

IDCategoryLast Update
0006959bugs2020-04-19 20:18
ReportershlomdanyAssigned Topaul 
Reproducibilityalways 
Status closedResolutionwon't fix 
PlatformArdourOSWindowsOS VersionWin 10
Product Version 
Fixed in Version 
Summary0006959: Cant select different Input / Output device in the Audio/MIDI Setup
DescriptionCant select 2 different ASIO drivers for Input device and Output device.
Steps To ReproduceGo To "Audio/MIDI Setup" window
Select "Driver" - ASIO
Select "Input device" - ASIO driver 'A'
Select "Output device" - ASIO driver 'B'

Hit OK and you will get an error "Failed to open audio device".

Only When Input device and output device are the same it will work.
TagsNo tags attached.

Activities

paul

2016-08-17 22:49

administrator   ~0018390

This is a known limitation. There are no plans to change it in the near future. ASIO provides no built-in resampling, which is necessary if the separate devices do not share the same sample clock. We don't plan to add resampling to any of the backends (ALSA, ASIO or CoreAudio) at any time soon.

We justify this by noting that Ardour is primarily targetting a market in which almost everyone would be expected to have a single, reasonable quality audio interface. We are not really that interested in people who want to (e.g.) use a USB microphone with their laptop speakers for output. If it was quick and easy to do, we might do it, but it isn't, and fundamentally, it is bad practice to work this way.

paul

2016-08-17 22:50

administrator   ~0018391

won't fix ... at any time in the near term future. No-one can tell what might happen beyond that.

shlomdany

2016-08-18 19:29

reporter   ~0018411

Ok, thanks for clearing this one out.

system

2020-04-19 20:18

developer   ~0023639

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-08-17 04:37 shlomdany New Issue
2016-08-17 22:49 paul Note Added: 0018390
2016-08-17 22:50 paul Note Added: 0018391
2016-08-17 22:50 paul Status new => resolved
2016-08-17 22:50 paul Resolution open => won't fix
2016-08-17 22:50 paul Assigned To => paul
2016-08-18 19:29 shlomdany Note Added: 0018411
2020-04-19 20:18 system Note Added: 0023639
2020-04-19 20:18 system Status resolved => closed