View Issue Details

IDCategoryLast Update
0006958bugs2016-08-25 01:10
ReportershlomdanyAssigned Topaul 
Reproducibilityalways 
Status assignedResolutionopen 
PlatformArdourOSWindowsOS Version10
Product Version 
Fixed in Version 
Summary0006958: Application crashes while recording- C++ Runtime error
DescriptionI am recording with Ardour, recording 64 / 32 mono channels.
Each time the application will crash with C++ runtime error after some time (between 30 min to 60 min).
Steps To ReproduceCreate new session:
Select your ASIO driver.
48Khz, 1024 buffer.
Open 64 mono channels.
Enable record all channels.
Start recording and wait for 60 min, at some point application will crash.
Additional InformationHappened on 4 different Win10 systems.
Windows application Crash dump attached.
TagsNo tags attached.

Relationships

duplicate of 0006478 closedx42 Crash after some time of recording 

Activities

shlomdany

2016-08-17 04:15

reporter  

Ardour crash.zip (693,728 bytes)

paul

2016-08-17 22:53

administrator   ~0018392

This has a high chance of being related to an extremely elusive bug that has been seen on 2 linux systems. We have been unable to develop a recipe for the bug and it is hard to generate without long recordings.

A workaround exists, however:

For ready-to-run versions of Ardour: goto Preferences > Editor > Waveforms and disable "Show waveforms .. while recording".

For self-build versions of Ardour, you can go one step further, and use --disable-threaded-waveforms at configure time.

We'd appreciate feedback on whether this fixes the crashes you're seeing, since it would at least confirm that it is the same bug.

paul

2016-08-17 22:55

administrator   ~0018393

Also, please note that crash dumps in this format are not useful to us, because we do not use Windows or Microsoft tools for development.

http://ardour.org/debugging_ardour has instructions on how to get backtraces from ardour on all platforms.

shlomdany

2016-08-18 04:39

reporter   ~0018401

Thank for your prompt reply !
I will try your workaround ASAP and will let you know the results.

shlomdany

2016-08-18 19:33

reporter   ~0018412

It looks like the workaround you suggested works. I didn't have any crashes today :-))
I will continue testing this and will update accordingly.

Thank you!

audiopartner_net

2016-08-24 23:36

reporter   ~0018475

Hi Paul,

here is my crash-file

audiopartner_net

2016-08-24 23:37

reporter   ~0018476

2016-08-24 16:36


      
 Hi Paul,

 here is my crash-file

paul

2016-08-25 01:10

administrator   ~0018477

audiopartnet_net: you do not seem to have attached the file. You need to use the button labelled "Attach" just below the bug report text itself.

Issue History

Date Modified Username Field Change
2016-08-17 04:15 shlomdany New Issue
2016-08-17 04:15 shlomdany File Added: Ardour crash.zip
2016-08-17 22:53 paul Note Added: 0018392
2016-08-17 22:53 paul Assigned To => paul
2016-08-17 22:53 paul Status new => feedback
2016-08-17 22:55 paul Note Added: 0018393
2016-08-18 01:56 x42 Relationship added duplicate of 0006478
2016-08-18 04:39 shlomdany Note Added: 0018401
2016-08-18 04:39 shlomdany Status feedback => assigned
2016-08-18 19:33 shlomdany Note Added: 0018412
2016-08-24 23:36 audiopartner_net Note Added: 0018475
2016-08-24 23:37 audiopartner_net Note Added: 0018476
2016-08-25 01:10 paul Note Added: 0018477