View Issue Details

IDCategoryLast Update
0006949bugs2018-03-29 14:43
ReporteruniusAssigned Tox42 
Reproducibilityalways 
Status resolvedResolutionnot fixable 
PlatformLinuxOSOS Version
Product Version 
Fixed in Version 
Summary0006949: QMidiArp not show own GUI
DescriptionQMidiArp plugins show only generic GUI. "Edit" in menu disabled, on double click open generic GUI
TagsNo tags attached.

Activities

x42

2016-08-14 19:32

administrator   ~0018370

Probably a QT4/QT5 issue.

Is that Ardour5 from ardour.org/download on Linux? What distro?

unius

2016-08-14 19:49

reporter   ~0018371

Last edited: 2016-08-14 19:54

View 2 revisions

Distro is own, QT5. But in Qtracktor all worked nice. Ardour 5.0.0 from git

x42

2016-08-14 19:56

administrator   ~0018372

Right qtractor is QT - so it'll work as long as qtractor is compiled with the same QT version as the plugin.

Ardour uses libsuil to bridge QT interfaces, and there is no qt5_in_gtk wrapper, only qt4_in_gtk. http://git.drobilla.net/cgit.cgi/suil.git/tree/src

You can get around this by compiling qmidiarp with qt4, maybe. If you're luck and get the QT4 ABI of libsuil to match.

But really long term no plugin GUI should use any of the desktop-ui toolkits, gtk/qt/wxwidgets etc are entirely inappropriate for plugin UI and will continue to break whenever the ABI changes.

unius

2016-08-14 20:09

reporter   ~0018373

Last edited: 2016-08-14 20:13

View 3 revisions

Ehhh ... Agree
But synthv1 from rncbc also in QT5, and yet worked in Ardour with own QT5 GUI ;)

paul

2016-08-17 22:59

administrator   ~0018394

Probably had no missing symbols, because it used QT4 compatible code.

unfa

2018-03-29 07:50

reporter   ~0020235

I have the same issue still wiht Ardour 5.12 from official sources under Linux Mint 18.3 with KDE5. QMidiArp / Seq / LFO plugins load and show their GUIs fine in Carla host, but not in Ardour. I can only control them with Generic GUI which unfortunately is not enough, because the custom GUI handles defining patterns.

unfa

2018-03-29 07:59

reporter   ~0020236

PS: The "Edit" menu item is enabled, clicking it doesn't seem to do anything, but there's an error in the Ardour console: "[ERROR]: failed to instantiate LV2 GUI".

I've run "ardour --gdb" and got this when clicking the "Edit" button:

suil error: Failed to open module /opt/ardour/lib/libsuil_qt5_in_gtk2.so (/usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.7' not found (required by /opt/ardour/lib/libsuil_qt5_in_gtk2.so))

unfa

2018-03-29 08:09

reporter   ~0020237

I've just installed qt5-default package to make sure I am not missing any libraries. No difference.
What is strange is that I have the mentioned library in my system:

$ locate libQt5Core.so.5
/usr/lib/x86_64-linux-gnu/libQt5Core.so.5

unius

2018-03-29 08:21

reporter   ~0020238

Now on my system GUI works perfectly. As I understand this the problem around libsuil_qt5_in_gtk2.so. It must have something to do with installed Qt libraries in OS

x42

2018-03-29 12:49

administrator   ~0020239

It's not fixable on our side.

It's been over 6 years that we keep reminding plugin-devs to make plugins self-contained (and not depend on external libs).

Mid/long-term we'll drop support for gtk and QT plugin UIs and only support native UIs: X11, Cocoa, HWND (and perhaps wayland).

unfa

2018-03-29 12:52

reporter   ~0020240

Alright, I'll notify the QMidiArp devs. It's strange for me that it works just fine in Carla though.

unfa

2018-03-29 12:54

reporter  

Selection_999(148).png (171,487 bytes)
Selection_999(148).png (171,487 bytes)

unfa

2018-03-29 12:54

reporter   ~0020241

Now what is super strange to me is that QMidiArp GUI works if I load it inside Carla Rack loaded inside Ardour - I've uploaded a screenshot.

x42

2018-03-29 14:00

administrator   ~0020242

Last edited: 2018-03-29 14:09

View 2 revisions

This is not strange.

Carla process-separates plugins. The plugin as well as its GUI run in a separate process (no conflict between QT4 and QT5 libs). Also Carla does not use libsuil but has dedicated bridges. Furthermore Carla itself is also written QT, so as long as the QT versions match this can work.

From Ardour's point-of-view, Carla the plugin is a X11 plugin (Ardour does not see any of QT in its memory-space).

Still this adds significant overhead (context switches) and is a workaround at best.

unfa

2018-03-29 14:43

reporter   ~0020243

Yeah, plus I get the feeling that the QMidiArp GUI doesn't function properly with this workaround in place. I seem to be unable to draw a pattern.

Issue History

Date Modified Username Field Change
2016-08-14 19:00 unius New Issue
2016-08-14 19:32 x42 Note Added: 0018370
2016-08-14 19:49 unius Note Added: 0018371
2016-08-14 19:54 unius Note Edited: 0018371 View Revisions
2016-08-14 19:56 x42 Note Added: 0018372
2016-08-14 20:09 unius Note Added: 0018373
2016-08-14 20:13 unius Note Edited: 0018373 View Revisions
2016-08-14 20:13 unius Note Edited: 0018373 View Revisions
2016-08-17 22:59 paul Note Added: 0018394
2018-03-29 07:50 unfa Note Added: 0020235
2018-03-29 07:59 unfa Note Added: 0020236
2018-03-29 08:09 unfa Note Added: 0020237
2018-03-29 08:21 unius Note Added: 0020238
2018-03-29 12:49 x42 Note Added: 0020239
2018-03-29 12:49 x42 Status new => resolved
2018-03-29 12:49 x42 Resolution open => not fixable
2018-03-29 12:49 x42 Assigned To => x42
2018-03-29 12:52 unfa Note Added: 0020240
2018-03-29 12:54 unfa File Added: Selection_999(148).png
2018-03-29 12:54 unfa Note Added: 0020241
2018-03-29 14:00 x42 Note Added: 0020242
2018-03-29 14:09 x42 Note Edited: 0020242 View Revisions
2018-03-29 14:43 unfa Note Added: 0020243