View Issue Details

IDCategoryLast Update
0006946bugs2020-04-19 20:18
ReportermhartzelAssigned Topaul 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformLinuxOSGentooOS VersionCurrent
Product Version5.0-pre 
Fixed in Version 
Summary0006946: Ardour 5 clocks can get stuck
DescriptionArdour 5.0.5

I stumbled across a way to get Ardour clock displays to get stuck and not show the current time anymore.
Steps To ReproducePreparation
- Create a session
- Change primary clock to show timecode
- Change secondary clock to show bars and beats

Reproducing the bug
- Click on secondary clock and press the enter - key
- Click on primary clock
- Click on secondary clock

Both of the clocks are now stuck
- Click on the timeline and press play: Clocks don't advance
TagsNo tags attached.

Activities

mhartzel

2016-08-25 23:08

reporter   ~0018484

This bug still exists on Ardour 5.1.

I should add that this procedure reveals a deeper bug in Ardour code. After you go through the procedure described above the clocks don't accept any input anymore (clicks or keyboard input) and if you now try to change the clock display format the clock turns into a black box with no display what so ever.

It seems that the code might be waiting for keyboard input to finish (return to be pressed) on one of the clocks, but Ardour doesn't realize that the focus has moved away from the clock that waits for the keyboard input.

This creates a deadlock situation that freezes both of the clocks totally.

mhartzel

2016-08-29 09:34

reporter   ~0018508

Still exists on Ardour 5.3

timbyr

2016-09-06 11:09

developer   ~0018551

I can confirm this issue exists in version 5.3 from ardour.org(linux 32bit)

paul

2016-09-06 20:30

administrator   ~0018552

This is now fixed in git. Ridiculously deep diving was needed to determine the source of the problem.

Please confirm the fix via a nightly build or your own.

timbyr

2016-09-07 00:45

developer   ~0018558

I can no longer reproduce with master@835b874e

mhartzel

2016-09-07 19:42

reporter   ~0018564

I can not reproduce this problem anymore with Ardour 5.3.54-g835b874. Thanks for digging in and fixing this. I hope the work done prevented some possible future complications with the clocks. I think the bugreport can be closed now.

paul

2016-09-07 19:48

administrator   ~0018566

see notes.

paul

2016-09-07 20:00

administrator   ~0018567

our convention is that developers can only mark a bug as "resolved". reporters get to close bugs when they are satisfied with the status.

system

2020-04-19 20:18

developer   ~0023638

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-08-14 17:29 mhartzel New Issue
2016-08-25 23:08 mhartzel Note Added: 0018484
2016-08-29 09:34 mhartzel Note Added: 0018508
2016-09-06 11:09 timbyr Note Added: 0018551
2016-09-06 11:09 timbyr Status new => confirmed
2016-09-06 20:30 paul Note Added: 0018552
2016-09-07 00:45 timbyr Note Added: 0018558
2016-09-07 19:42 mhartzel Note Added: 0018564
2016-09-07 19:48 paul Note Added: 0018566
2016-09-07 19:48 paul Status confirmed => resolved
2016-09-07 19:48 paul Resolution open => fixed
2016-09-07 19:48 paul Assigned To => paul
2016-09-07 20:00 paul Note Added: 0018567
2020-04-19 20:18 system Note Added: 0023638
2020-04-19 20:18 system Status resolved => closed