View Issue Details

IDCategoryLast Update
0006930features2020-04-19 20:18
ReporterlpirlAssigned Tox42 
ReproducibilityN/A 
Status closedResolutionfixed 
Product Version 
Fixed in Version 
Summary0006930: spectral analysis: display exact frequency and value
DescriptionIn the spectral analysis, it can be hard to determine exact frequencies of peaks/notches, especially somewhere between the grid lines.
The same is true for the corresponding dB value.

It would be nice to have the coordinates (dB value, frequency) displayed when mouse-hovering over the chart.
Additional InformationThis is captured from an email:

On 07/22/2016 03:59 PM, "fred <f.rech@yahoo.fr>" wrote as excerpted:
> in one of my dreams, that excessive peak between 2k and 7k, if I
> put the mouse over a pop-up says "4321Hz"..
TagsNo tags attached.

Activities

_FrnchFrgg_

2016-07-23 21:35

developer   ~0018318

I wrote https://github.com/Ardour/ardour/commit/53a6c098ae3069da51946826ea48a970a3f35e99 and https://github.com/Ardour/ardour/commit/02c5bffb8c31a97e87c0ef69d23adeb026ae65e0 to handle this request.

In the plugin analysis fft, both frequency and dB values are shown, but for now only the frequency is shown for the spectral analysis window. The reason is that minimum dB, maximum dB, and even the top margin are computed again on every redraw. In my opinion this is too costly to run on each mouseover event.

The good way to solve that would be to cache these values and invalidate when needed, but for now I kept this simple until I am certain that the feature is indeed wanted and implemented satisfactorily.

x42

2016-07-24 11:14

administrator   ~0018320

Spectral Analysis window includes displays the freq since Ardour 5.0-pre1-12-g7897b75

Since it's a long-term integrated value, dBFS display does not make much sense. A [relative] dB display could sense when combined with markers or distance measurement (peak vs noise or peak-to-peak-band).


PS. I'm not convinced loudness-analysis needs this, a lot more useful would be to allow to move the editor-playhead to a position corresponding to a point in the Loudness Analysis window (but for post-export that opens a can of worms, so alas, it's not going to happen soonish).

_FrnchFrgg_

2016-07-26 06:14

developer   ~0018323

This bug can be closed, right ?

x42

2016-07-26 08:50

administrator   ~0018324

Spectrum analysis Freq display was added in Ardour 5.0-pre1-12-g7897b75
and plugin-analysis in 5.0-pre1-24-g46c311b

Please test

lpirl

2016-08-25 09:48

reporter   ~0018480

Excellent, thanks a lot everyone!
(I'd find dBFS display "interesting" as well but it's by far less informative than the frequency, correct – so that's not important)

system

2020-04-19 20:18

developer   ~0023630

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-07-23 10:20 lpirl New Issue
2016-07-23 21:35 _FrnchFrgg_ Note Added: 0018318
2016-07-24 11:14 x42 Note Added: 0018320
2016-07-26 06:14 _FrnchFrgg_ Note Added: 0018323
2016-07-26 08:50 x42 Note Added: 0018324
2016-07-26 08:50 x42 Status new => resolved
2016-07-26 08:50 x42 Resolution open => fixed
2016-07-26 08:50 x42 Assigned To => x42
2016-08-25 09:48 lpirl Note Added: 0018480
2020-04-19 20:18 system Note Added: 0023630
2020-04-19 20:18 system Status resolved => closed