View Issue Details

IDCategoryLast Update
0006929bugs2018-12-27 09:42
ReporterunfaAssigned Topaul 
Reproducibilityalways 
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSKX Studio (Ubuntu + KDE4)OS Version14.04.f
Product Version4.7 
Fixed in Version 
Summary0006929: MIDI tracks not affected by looped playback
DescriptionWhen using the loop playback option, MIDI tracks behave like the looping is disabled and play forward beyond the loop stop marker.

This makes it very hard to work with synthesizers to program patches while playing back a sequenced MIDI part.
Steps To Reproduce1. Create a new session;
2. Add one Audio and one MIDI track;
3. Record some audio;
4. Record some midi on top of the audio and after, so the MIDI lasts longer;
5. Create a loop range containing only the part where audio and midi plays together, so there is some MIDI recorded after the loop region ends;
6. Loop playback;
7. Listen as the audio track loops, while the MIDI track plays back once and plays events that are outside the loop markers.
TagsNo tags attached.

Activities

_FrnchFrgg_

2016-07-24 09:30

developer   ~0018319

I cannot reproduce in ardour 5.0pre1. Can you test in a nightly (nightly.ardour.org) ?

unfa

2016-07-26 12:19

reporter   ~0018325

I cannot reporduce this in 5.0-pre either.

Looks like it's fixed.

paul

2016-07-26 12:44

administrator   ~0018327

see notes.

Issue History

Date Modified Username Field Change
2016-07-22 15:00 unfa New Issue
2016-07-24 09:30 _FrnchFrgg_ Note Added: 0018319
2016-07-26 06:14 _FrnchFrgg_ Status new => feedback
2016-07-26 12:19 unfa Note Added: 0018325
2016-07-26 12:19 unfa Status feedback => new
2016-07-26 12:44 paul Note Added: 0018327
2016-07-26 12:44 paul Status new => resolved
2016-07-26 12:44 paul Resolution open => fixed
2016-07-26 12:44 paul Assigned To => paul