View Issue Details

IDCategoryLast Update
0006925bugs2020-04-19 20:18
Reporter_FrnchFrgg_Assigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformDebianOSLinuxOS Version4.6.2
Product Version5.0-pre 
Fixed in Version 
Summary0006925: inserts on busses don't show in Ardour's routing grid
Descriptioncontrary to inserts on tracks.
they can still be connected to/from with Patchage if using JACK
TagsNo tags attached.

Activities

x42

2016-07-16 00:42

administrator   ~0018299

no need for patchage. Window > Audio Connection Manager also does the trick

x42

2016-07-16 00:46

administrator   ~0018300

I can't reproduce. Audio Inserts on Busses are listed under Ardour Busses.

Do you mean Midi Busses & MIDI sends (which are currently still filed under audio connections)?

_FrnchFrgg_

2016-07-16 10:28

developer   ~0018302

Create two tracks, and a bus.
Create an insert on both track 2 and the bus.
Click on the input of track 1 to get its routing grid.
The insert on track 2 appears in the grid, but the insert on the bus does not.

Sorry for the lack of repoduce instructions, I filed the bug late yesterday as a reminder to self.

x42

2016-07-17 00:32

administrator  

bus_insert.png (20,880 bytes)
bus_insert.png (20,880 bytes)

x42

2016-07-17 00:32

administrator  

track_insert.png (19,887 bytes)
track_insert.png (19,887 bytes)

x42

2016-07-17 00:33

administrator   ~0018307

both display here, just under different "tabs"

_FrnchFrgg_

2016-07-17 10:39

developer   ~0018308

OK, so this might be only with MIDI ports of inserts. I'll check.

_FrnchFrgg_

2016-07-18 14:48

developer   ~0018310

I debugged a bit more, and inserts with MIDI-only show up when trying to make connections from/to audio channels, but not from/to MIDI channels. Probably a problem trying to match the DataTypes... I'm still deciphering PortMatrix and its subclasses.

_FrnchFrgg_

2016-07-20 19:12

developer   ~0018313

Fixed

system

2020-04-19 20:18

developer   ~0023628

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-07-15 23:56 _FrnchFrgg_ New Issue
2016-07-16 00:42 x42 Note Added: 0018299
2016-07-16 00:46 x42 Note Added: 0018300
2016-07-16 00:46 x42 Assigned To => x42
2016-07-16 00:46 x42 Status new => feedback
2016-07-16 10:28 _FrnchFrgg_ Note Added: 0018302
2016-07-16 10:28 _FrnchFrgg_ Status feedback => assigned
2016-07-17 00:32 x42 File Added: bus_insert.png
2016-07-17 00:32 x42 File Added: track_insert.png
2016-07-17 00:33 x42 Note Added: 0018307
2016-07-17 10:39 _FrnchFrgg_ Note Added: 0018308
2016-07-18 14:48 _FrnchFrgg_ Note Added: 0018310
2016-07-20 19:12 _FrnchFrgg_ Note Added: 0018313
2016-07-20 19:12 _FrnchFrgg_ Status assigned => resolved
2016-07-20 19:12 _FrnchFrgg_ Resolution open => fixed
2020-04-19 20:18 system Note Added: 0023628
2020-04-19 20:18 system Status resolved => closed