View Issue Details

IDCategoryLast Update
0006920bugs2020-04-19 20:18
Reporter_FrnchFrgg_Assigned To_FrnchFrgg_ 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformDebianOSLinuxOS Version4.6.2
Product Version5.0-pre 
Fixed in Version 
Summary0006920: Aux sends and external sends want audio tracks even if there is only MIDI at that point
DescriptionIn a MIDI only track, if you try to create an aux send it only proposes audio busses (which doesn't make sense at that point) and doesn't propose midi busses.

Similarly, if you create an External Send, it creates a jack port with two audio channels and no midi, which doesn't match the track configuration at that point. (if you remove the audio channels and add a midi track, then the send works as intended).
TagsNo tags attached.

Activities

_FrnchFrgg_

2016-07-09 00:26

developer   ~0018294

Part of this is fixed by https://github.com/Ardour/ardour/pull/242

_FrnchFrgg_

2016-07-15 21:23

developer   ~0018298

https://github.com/Ardour/ardour/pull/248 has been sent for the part about external sends.

system

2020-04-19 20:18

developer   ~0023626

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-07-06 16:17 _FrnchFrgg_ New Issue
2016-07-09 00:26 _FrnchFrgg_ Note Added: 0018294
2016-07-15 21:23 _FrnchFrgg_ Note Added: 0018298
2016-07-16 10:56 _FrnchFrgg_ Status new => resolved
2016-07-16 10:56 _FrnchFrgg_ Resolution open => fixed
2016-07-16 10:56 _FrnchFrgg_ Assigned To => _FrnchFrgg_
2020-04-19 20:18 system Note Added: 0023626
2020-04-19 20:18 system Status resolved => closed