View Issue Details

IDCategoryLast Update
0006864bugs2020-04-19 20:18
ReporterLeatuspenguinAssigned ToLeatuspenguin 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformLinuxOSDebianOS VersionJessie
Product Version4.7 
Fixed in Version 
Summary0006864: Tabbed development - Alt + M doesn't work as expected when editor/mixer tabs are detached
DescriptionIn the current master branch, Alt + M works as expected when the editor/mixer views are attached as tabs. When either of these are detached, Alt + M doesn't as expected.
Steps To Reproduce- Start a session and detach the editor tab
- Use the Alt + M shortcut

Result - Ardour switches to the main window after Alt + M, but doesn't go back to the editor window when pressed again.

- Reattach editor window
- Detach mixer tab
- Use the Alt + M shortcut

Result - The shortcut doesn't respond

- Switch back to the main editor + transport controls view
- Use the Alt + M shortcut

Result - The shortcut switches to the mixer window but when pressed doesn't switch back to the editor + transport controls view
Additional InformationAlt + M shortcut should respond as before and be consistent with the tab behavior.
TagsNo tags attached.

Activities

colinf

2016-09-02 10:41

updater   ~0018537

I'm still seeing this behaviour: <Alt>+M when detached mixer window has focus does nothing here (5.3-34-gd787948). This is under xfce 4.12 from debian testing, if that makes any difference.

colinf

2016-09-02 12:59

updater   ~0018538

Ah, forget that: now it works...

Leatuspenguin

2016-09-02 18:19

reporter   ~0018539

Last edited: 2016-09-02 18:21

View 2 revisions

@colinf - I think I have come across the same issue as you. This has mostly been fixed and works 99% of the time. Very rarely it stops working with detached tabs. When it does I have noticed that reattaching and detaching again brings it back to normal. I have observed this with xfce and mate environments.

I still haven't found what causes it to rarely stop working but if I find out the recipe, I will reopen this ticket with reproducible details.

system

2020-04-19 20:18

developer   ~0023613

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-04-26 22:20 Leatuspenguin New Issue
2016-07-02 14:13 Leatuspenguin Status new => resolved
2016-07-02 14:13 Leatuspenguin Resolution open => fixed
2016-07-02 14:13 Leatuspenguin Assigned To => Leatuspenguin
2016-09-02 10:41 colinf Note Added: 0018537
2016-09-02 12:59 colinf Note Added: 0018538
2016-09-02 18:19 Leatuspenguin Note Added: 0018539
2016-09-02 18:21 Leatuspenguin Note Edited: 0018539 View Revisions
2020-04-19 20:18 system Note Added: 0023613
2020-04-19 20:18 system Status resolved => closed