View Issue Details

IDCategoryLast Update
0006848bugs2020-04-19 20:18
ReporterefenstorAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformPC AMD64OSDebian LinuxOS VersionJessie
Product Version4.7 
Fixed in Version 
Summary0006848: Freeze when deleting a region
DescriptionArdour freezes when deleting a specific region. Some other operations (drag, move edges, etc.) on the other regions can cause the same as well but I can't find the exact combination.
Steps To Reproduce1. Load the attached project file. I have removed all the wave files, so select "skip all missing files" - it does not affect the behavior.
2. Select the "Ac. 1b" region (it's the single one).
3. Press "Delete" - Ardour freezes

Some additional testing:
1. Load the same project again
2. Drag a little bit the right edge of the top-right "Ac. 1" region of the "Ac.Guitar m1" track
3. Try to delete the "Ac. 1b" region again - it is now deleted successfully
4. Undo
5. Drag the right edge of the top-right region back so that it is aligned with the others
6. Try to delete the "Ac. 1b" region - Ardour freezes
Additional InformationThe problem is present in Ardour 4.7.0 and 4.7.503. I recorded both tracks simultaneously in a group, multiple takes are the layers.
TagsNo tags attached.

Users sponsoring this issue
Sponsors List Total Sponsorship = US$ 5

2016-03-29 19:59: efenstor (US$ 5)
Users sponsoring this issue (Total Sponsorship = US$ 5)

Activities

efenstor

2016-03-29 19:47

reporter  

project.tar.gz (9,282 bytes)

efenstor

2016-03-29 20:21

reporter   ~0018095

Just checked: the problem is present in all the previous versions that I can test (4.6.0, 4.4.0 and 4.2.214).

x42

2016-05-17 00:30

administrator   ~0018202

I can reproduce it with latest git. Thanks for the session that'll be handy to track things down

x42

2016-05-17 01:05

administrator   ~0018203

fixed in Ardour 4.7-1025-g0049904 - please test

efenstor

2016-05-21 20:30

reporter   ~0018213

Confirmed. The problem's resolved now, thank you!

system

2020-04-19 20:18

developer   ~0023611

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-03-29 19:47 efenstor New Issue
2016-03-29 19:47 efenstor File Added: project.tar.gz
2016-03-29 19:59 efenstor Sponsorship Added efenstor: US$ 5
2016-03-29 19:59 efenstor Sponsorship Total 0 => 5
2016-03-29 20:21 efenstor Note Added: 0018095
2016-05-17 00:30 x42 Note Added: 0018202
2016-05-17 01:05 x42 Note Added: 0018203
2016-05-17 01:05 x42 Status new => resolved
2016-05-17 01:05 x42 Resolution open => fixed
2016-05-17 01:05 x42 Assigned To => x42
2016-05-21 20:30 efenstor Note Added: 0018213
2020-04-19 20:18 system Note Added: 0023611
2020-04-19 20:18 system Status resolved => closed