View Issue Details

IDCategoryLast Update
0006842bugs2020-04-19 20:18
ReportermhartzelAssigned Tox42 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformLinuxOSGentooOS VersionGentoo
Product Version4.7 
Fixed in Version 
Summary0006842: Copying automation data results it being on different level than the original
DescriptionCopying and pasting automation data (for example volume automation) from one place on a track to another results the data being at wrong volume level.

Ardour 4.7 on Gentoo Linux. Ardour binary downloaded from Ardour.org

Steps To ReproduceHow to reproduce.

- Create a new session and 1 audio track to it.
- Jump to 10 seconds on the time line.
- Show volume fader automation on the audio track
- Set automation mode to touch
- Play the session and move the volume fader up and down. This will record the fader movement as automation data.
- Stop playback
- Select Range mouse-tool and select the volume automation you just recorded
- Use keyboard shortcuts ctrl + c and ctrl + p to paste the volume automation to a later time on the track.
- Now you have two copies of the automation data. Move the red play pointer that shows the current time position of the session on a automation point on the first set of automation and check the volume level the automation volume fader shows there.
- Move the play pointer to the corresponding place on the copied automation and check the volume level the volume fader shows.

Result: The copied automation is much higher in level (several dB's) than the original.

Expected result: the copied automation is exactly at the same level as the original.

I've see this unexpected behaviour on both audio track volume and bus send automation.
TagsNo tags attached.

Activities

x42

2016-03-28 17:27

administrator   ~0018084

possibly on all "logscale" automation lanes. I just tried and the resulting shape looks like this conversion from log-scale to log-scale with different range.

x42

2016-03-28 19:46

administrator   ~0018087

fixed in Ardour 4.7-503-ga5b06c5 - please test

mhartzel

2016-03-29 08:31

reporter   ~0018091

Seems to be fixed in 4.7.503, thanks :)

system

2020-04-19 20:18

developer   ~0023610

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-03-28 17:11 mhartzel New Issue
2016-03-28 17:27 x42 Note Added: 0018084
2016-03-28 19:46 x42 Note Added: 0018087
2016-03-28 19:46 x42 Assigned To => x42
2016-03-28 19:46 x42 Status new => feedback
2016-03-29 08:31 mhartzel Note Added: 0018091
2016-03-29 08:31 mhartzel Status feedback => assigned
2016-03-29 18:59 x42 Status assigned => resolved
2016-03-29 18:59 x42 Resolution open => fixed
2020-04-19 20:18 system Note Added: 0023610
2020-04-19 20:18 system Status resolved => closed