View Issue Details

IDCategoryLast Update
0006841bugs2020-04-19 20:18
Reporterjohne53Assigned Tojohne53 
Reproducibilityalways 
Status closedResolutionfixed 
PlatformPCOSWindowsOS VersionWin 8.1
Product Version4.7 
Fixed in Version 
Summary0006841: Current code is crashing if I select 'Window->Bindings Editor'
DescriptionIf I load a session (in either the current build of Mixbus or Ardour) I see a crash if I select 'Window->Bindings Editor'

Selecting that option ends up calling 'KeyEditor::search_string_updated()' - which in turn calls 'KeyEditor::current_tab()'

'KeyEditor::current_tab()' returns NULL. So I'm guessing that we somehow haven't set up a current tab for the Bindings editor.
Additional Information2 points might be significant:-

1) I discovered this in my MSVC build but I assume it also affects gcc build(s).

2) The keybindigs editor stuff got changed a week or two ago, so I'm guessing that's where the problem crept in.
TagsNo tags attached.

Activities

johne53

2016-03-28 13:39

reporter   ~0018083

This seems to be related to my previous bug report about mismatched text case:-

http://tracker.ardour.org/view.php?id=6834

In other words, if I open my file "ardour.keys" and I then capitalize the entries for each Bindings name, the crash goes away (i.e. the Bindings Editor window then gets displayed correctly).

napcode

2016-03-28 18:26

reporter   ~0018085

The changes to the bindings rendered old "ardour.keys" files invalid. Deleting and recreating the file should work fine. I created a pull request to prevent that particular crash but the keyeditor will be empty in these cases.

johne53

2016-03-29 07:05

reporter   ~0018090

What do I need to do to recreate ardour.keys? Deleting it doesn't cause a new one to get generated (unless I'm missing something...)

johne53

2016-04-05 10:57

reporter   ~0018132

This seems to have been fixed by Commit 1316e85d (Mathias Buhr - 28-Mar-2016).

FWIW 'ardour.keys' still contains the wrong capitalization (so the Bindings window is empty when opened) but at least it doesn't crash any more.

napcode

2016-04-05 11:03

reporter   ~0018133

This file should be created/updated when you customize the default keybindings, e.g. when you edit them via the dialog.

johne53

2016-04-05 11:34

reporter   ~0018134

Thanks napcode. The problem is that if the file is missing / corrupted / wrongly capitalized etc, nothing shows up in the dialog (so there's nothing available to edit).

napcode

2016-04-05 13:12

reporter   ~0018135

Yes, I know. Did you delete that file? Maybe there is another one to delete as well. In any case it should work if you delete/rename ardours cfg folder.

system

2020-04-19 20:18

developer   ~0023609

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-03-28 11:33 johne53 New Issue
2016-03-28 13:39 johne53 Note Added: 0018083
2016-03-28 18:26 napcode Note Added: 0018085
2016-03-29 07:05 johne53 Note Added: 0018090
2016-04-05 10:57 johne53 Note Added: 0018132
2016-04-05 10:57 johne53 Status new => resolved
2016-04-05 10:57 johne53 Resolution open => fixed
2016-04-05 10:57 johne53 Assigned To => johne53
2016-04-05 11:03 napcode Note Added: 0018133
2016-04-05 11:34 johne53 Note Added: 0018134
2016-04-05 13:12 napcode Note Added: 0018135
2020-04-19 20:18 system Note Added: 0023609
2020-04-19 20:18 system Status resolved => closed