View Issue Details

IDCategoryLast Update
0006830features2020-04-19 20:17
Reporter8p8cAssigned Tox42 
Reproducibilityunable to reproduce 
Status closedResolutionfixed 
PlatformUbuntuOSLinuxOS VersionMaverick
Product Version4.7 
Fixed in Version 
Summary0006830: Patch selection via drop down for MIDI hardware
DescriptionThere used to be a second drop down menu to select patches in a midi track.

It is possible to select the device, but it is not possible to select the patches by name via the MIDNAM, except for Generic and General Midi / Midi

For example, you could select the hardware such as a Roland XV-3080, and the bank select would be possible via the drop down, with patch names.
Steps To ReproduceN/A - only previous versions to 4.7 have this, I'm not sure up to which version.
Additional InformationI'd really love to see this re-implemented, it worked excellently.
TagsNo tags attached.

Users sponsoring this issue
Sponsors List Total Sponsorship = US$ 20

2016-03-21 23:56: 8p8c (US$ 20)
Users sponsoring this issue (Total Sponsorship = US$ 20)

Activities

x42

2016-12-22 00:15

administrator   ~0019208

There was no code to generate immediate patch changes..

But in any case, since Ardour 5.5-43-gac814d3 the context menu in a midi track's header allows to send them.

midi-track-header right-click > Select Patch > Channel X -> patch NNN;

Names and banks from MIDNAM are used if available.

system

2020-04-19 20:17

developer   ~0023605

Issue has been closed automatically, by Trigger Close Plugin.
Feel free to re-open with additional information if you think the issue is not resolved.

Issue History

Date Modified Username Field Change
2016-03-21 23:55 8p8c New Issue
2016-03-21 23:56 8p8c Sponsorship Added 8p8c: US$ 20
2016-03-21 23:56 8p8c Sponsorship Total 0 => 20
2016-12-22 00:15 x42 Note Added: 0019208
2016-12-22 00:15 x42 Status new => resolved
2016-12-22 00:15 x42 Resolution open => fixed
2016-12-22 00:15 x42 Assigned To => x42
2020-04-19 20:17 system Note Added: 0023605
2020-04-19 20:17 system Status resolved => closed