View Issue Details

IDCategoryLast Update
0006809bugs2016-03-04 15:58
ReporterjforbergAssigned To 
Reproducibilityalways 
Status newResolutionopen 
PlatformOSLinuxOS Version4.4.1-2
Product Version4.6 
Fixed in Version 
Summary0006809: Startup gets stuck in loop loading in themes
DescriptionWhen starting up ardour, it enters an infinite loop while trying to load GTK themes.

Strace excerpt:

access("/usr/share/themes/Adwaita/gtk-2.0/Shadows/frame.png", F_OK) = 0
access("/usr/share/themes/Adwaita/gtk-2.0/Shadows/frame.png", F_OK) = 0
access("/usr/share/themes/Adwaita/gtk-2.0/Shadows/frame.png", F_OK) = 0
access("/usr/share/themes/Adwaita/gtk-2.0/Shadows/frame-gap-start.png", F_OK) = 0
access("/usr/share/themes/Adwaita/gtk-2.0/Shadows/frame-gap-end.png", F_OK) = 0
access("/usr/share/themes/Adwaita/gtk-2.0/Shadows/frame.png", F_OK) = 0
access("/usr/share/themes/Adwaita/gtk-2.0/Shadows/frame.png", F_OK) = 0
access("/usr/share/themes/Adwaita/gtk-2.0/Shadows/frame-gap-start.png", F_OK) = 0
access("/usr/share/themes/Adwaita/gtk-2.0/Shadows/frame-gap-end.png", F_OK) = 0
access("/usr/share/themes/Adwaita/gtk-2.0/Shadows/frame.png", F_OK) = 0
access("/usr/share/themes/Adwaita/gtk-2.0/Shadows/frame.png", F_OK) = 0
access("/usr/share/themes/Adwaita/gtk-2.0/Shadows/frame-gap-start.png", F_OK) = 0
access("/usr/share/themes/Adwaita/gtk-2.0/Shadows/frame-gap-end.png", F_OK) = 0
access("/usr/share/themes/Adwaita/gtk-2.0/Shadows/frame.png", F_OK) = 0
access("/usr/share/themes/Adwaita/gtk-2.0/Shadows/frame.png", F_OK) = 0
access("/usr/share/themes/Adwaita/gtk-2.0/Shadows/frame-gap-start.png", F_OK) = 0
access("/usr/share/themes/Adwaita/gtk-2.0/Shadows/frame-gap-end.png", F_OK) = 0

etc. similar output of read() and access() from /usr/share/themes
Steps To ReproduceLaunch ardour
Additional InformationOs is Arch Linux, reproducible on ardour versions 4.5 and 4.6

Built directly from git source with command line

  python2 waf configure --prefix=/usr \
                        --configdir=/etc \
                        --with-backends="jack,alsa" \
                        --libjack=weak \
                        --optimize \
                        --docs \
                        --cxx11 \
                        --no-phone-home

  python2 waf build $MAKEFLAGS
TagsNo tags attached.

Relationships

duplicate of 0005605 resolvedx42 Hangs while starting at loading UI config files 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2016-03-02 16:06 jforberg New Issue
2016-03-04 15:58 x42 Relationship added duplicate of 0005605