View Issue Details

IDCategoryLast Update
0006638other2018-12-27 09:39
Reporter3soulzAssigned Totnaugle 
Reproducibilityalways 
Status resolvedResolutionunable to reproduce 
Product Version4.X git (version in description) 
Fixed in Version 
Summary0006638: build failure
Descriptionversion 4.2.0

When building with ./waf install - build failed due to missing file:

/Ardour-4.2.0/libs/ardouralsautil/devicelist.h

located file as

/Ardour-4.2.0/libs/ardouralsautil/ardouralsautil/devicelist.h

After copying file to parent directory build succeeded. Unsure if this is specific to my system, though all files were used unchanged as unpacked from

Ardour-4.2.0.tar.bz2

from http://community.ardour.org/s/source
Additional InformationLinux Mint 17.2 64-bit
kernel 3.16.0-38-generic
TagsNo tags attached.

Activities

x42

2015-10-16 16:23

administrator   ~0017471

ardouralsautil/devicelist.h is the correct location. All includes in the sources are
  #include "ardouralsautil/devicelist.h
and the -I include path is set to libs/ardouralsautil

If this problem still exist with Ardour 4.4, could you please post the compilation log?

3soulz

2015-10-19 17:21

reporter   ~0017496

Last edited: 2015-10-19 17:21

Unfortunately I've been having some system issues after installing the custom cairo dependency. Until I can figure it out I can't rebuild Ardour

tnaugle

2016-01-13 21:45

developer   ~0017783

The current version of ardour is now 4.6 and no further information has been posted. If this is still a problem, please reopen the bug. Thanks

napcode

2016-02-19 21:54

reporter   ~0017972

I just reproduced this issue: it occurs when building on linux with jack being the only backend. The reason is that libs/backends/jack depends on libs/ardouralsautils which is not being build when ALSA-backend is not selected to build.

x42

2016-02-19 22:33

administrator   ~0017973

Works fine here with ardour 4.7 and

./waf configure --strict --prefix=/usr --configdir=/etc --ptformat --with-backends=jack --optimize

libs/ardouralsautil/wscript does build libardourlalsautil regardless of the ALSA backend (only `ardour-request-device` is optional). But you do need the ALSA headers (libasound2-dev).

napcode

2016-02-20 09:52

reporter   ~0017974

Hmm, sorry. I just tried to rereproduce this using the current master and it works fine. Don't know what I did differently last night.

user3580

2018-12-27 09:39

  ~0020550

Must be like to visit here this great article it is the amazing way to access here https://windowsclassroom.com/disable-touch-screen-windows-10 the function for how to disable touch screen windows 10 and save the all setting for batter working.

Issue History

Date Modified Username Field Change
2015-10-13 15:44 3soulz New Issue
2015-10-16 16:23 x42 Note Added: 0017471
2015-10-19 17:21 3soulz Note Added: 0017496
2015-10-19 17:21 3soulz Note Edited: 0017496
2016-01-13 21:45 tnaugle Note Added: 0017783
2016-01-13 21:45 tnaugle Status new => resolved
2016-01-13 21:45 tnaugle Resolution open => unable to reproduce
2016-01-13 21:45 tnaugle Assigned To => tnaugle
2016-02-19 21:54 napcode Note Added: 0017972
2016-02-19 22:33 x42 Note Added: 0017973
2016-02-20 09:52 napcode Note Added: 0017974
2018-12-27 09:39 user3580 Note Added: 0020550